summaryrefslogtreecommitdiff
path: root/gnu/packages/bioinformatics.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2024-01-02 21:40:44 +0100
committerRicardo Wurmus <rekado@elephly.net>2024-01-02 21:40:44 +0100
commitfb3ac987c94e0a77b5c39913dace0b565afc3291 (patch)
tree838323cb1756556805434ff030336c6560dde74d /gnu/packages/bioinformatics.scm
parente8814809c2de6fe2f23169775207b3d2e537724f (diff)
downloadguix-patches-fb3ac987c94e0a77b5c39913dace0b565afc3291.tar
guix-patches-fb3ac987c94e0a77b5c39913dace0b565afc3291.tar.gz
gnu: Add r-wasabi.
* gnu/packages/bioinformatics.scm (r-wasabi): New variable. Change-Id: I5ce6c47f1fb3b1d5dfedd0977e53cb70ce379077
Diffstat (limited to 'gnu/packages/bioinformatics.scm')
-rw-r--r--gnu/packages/bioinformatics.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 56219c55a5..e03eb21531 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -1192,6 +1192,32 @@ shape. This package provides an @code{htmlwidget} for building streamgraph
visualizations.")
(license license:expat))))
+(define-public r-wasabi
+ (let ((commit "8c33cabde8d18c2657cd6e38e7cb834f87cf9846")
+ (revision "1"))
+ (package
+ (name "r-wasabi")
+ (version (git-version "1.0.1" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/COMBINE-lab/wasabi")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0rpdj6n4cnx8n2zl60dzgl638474sg49dknwi9x3qb4g56dpphfa"))))
+ (properties `((upstream-name . "wasabi")))
+ (build-system r-build-system)
+ (propagated-inputs (list r-data-table r-rhdf5 r-rjson))
+ (home-page "https://github.com/COMBINE-lab/wasabi")
+ (synopsis "Use Sailfish and Salmon with Sleuth")
+ (description
+ "This package converts the output of the Sailfish and Salmon RNA-seq
+quantification tools so that it can be used with the Sleuth differential
+analysis package.")
+ (license license:bsd-3))))
+
(define-public pbbam
(package
(name "pbbam")