summaryrefslogtreecommitdiff
path: root/gnu/packages/bioinformatics.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2022-01-27 22:06:26 +0100
committerRicardo Wurmus <rekado@elephly.net>2022-01-27 22:15:25 +0100
commitc6bf89cff07802f5ebc7f1b1deb2e390641ec1b6 (patch)
tree99c5341068e02ba0f44db906d5f2d708a0e13970 /gnu/packages/bioinformatics.scm
parentb72f5255b09d0440d657bafbf07b2181c3a0b7d6 (diff)
downloadguix-patches-c6bf89cff07802f5ebc7f1b1deb2e390641ec1b6.tar
guix-patches-c6bf89cff07802f5ebc7f1b1deb2e390641ec1b6.tar.gz
gnu: pigx-rnaseq: Fix Python module capture.
The build system expects all Python modules to be on PYTHONPATH. * gnu/packages/bioinformatics.scm (pigx-rnaseq)[arguments]: Set PYTHONPATH variable in new build phase.
Diffstat (limited to 'gnu/packages/bioinformatics.scm')
-rw-r--r--gnu/packages/bioinformatics.scm3
1 files changed, 3 insertions, 0 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index c872c9c45a..e501c84265 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -10895,6 +10895,9 @@ once. This package provides tools to perform Drop-seq analyses.")
(add-before 'bootstrap 'autoreconf
(lambda _
(invoke "autoreconf" "-vif")))
+ (add-before 'configure 'set-PYTHONPATH
+ (lambda _
+ (setenv "PYTHONPATH" (getenv "GUIX_PYTHONPATH"))))
(add-before 'check 'set-timezone
;; The readr package is picky about timezones.
(lambda* (#:key inputs #:allow-other-keys)