summaryrefslogtreecommitdiff
path: root/gnu/packages/bioconductor.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2021-06-21 17:51:43 +0200
committerRicardo Wurmus <rekado@elephly.net>2021-06-21 17:53:26 +0200
commita41bddd29d60ba37ce13f3f34b466ae8008db27e (patch)
tree297007e5e91b242a73a4a792585d0aca169e33c6 /gnu/packages/bioconductor.scm
parent278e1c090e8b567169934de293649abf268eae53 (diff)
downloadguix-patches-a41bddd29d60ba37ce13f3f34b466ae8008db27e.tar
guix-patches-a41bddd29d60ba37ce13f3f34b466ae8008db27e.tar.gz
gnu: Add r-batchelor.
* gnu/packages/bioconductor.scm (r-batchelor): New variable.
Diffstat (limited to 'gnu/packages/bioconductor.scm')
-rw-r--r--gnu/packages/bioconductor.scm43
1 files changed, 43 insertions, 0 deletions
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index 1d4a033038..fd9d80cbdf 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -6236,6 +6236,49 @@ methods for operating on the delayed matrix of residuals, most notably matrix
multiplication and calculation of row/column sums or means.")
(license license:gpl3)))
+(define-public r-batchelor
+ (package
+ (name "r-batchelor")
+ (version "1.8.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "batchelor" version))
+ (sha256
+ (base32
+ "1xm204wp3m3mmlc1s59lscbbjvwm5nj32vvf16njcg7pb32lsiqa"))))
+ (properties `((upstream-name . "batchelor")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-beachmat" ,r-beachmat)
+ ("r-biocgenerics" ,r-biocgenerics)
+ ("r-biocneighbors" ,r-biocneighbors)
+ ("r-biocparallel" ,r-biocparallel)
+ ("r-biocsingular" ,r-biocsingular)
+ ("r-delayedarray" ,r-delayedarray)
+ ("r-delayedmatrixstats" ,r-delayedmatrixstats)
+ ("r-igraph" ,r-igraph)
+ ("r-matrix" ,r-matrix)
+ ("r-rcpp" ,r-rcpp)
+ ("r-residualmatrix" ,r-residualmatrix)
+ ("r-s4vectors" ,r-s4vectors)
+ ("r-scaledmatrix" ,r-scaledmatrix)
+ ("r-scuttle" ,r-scuttle)
+ ("r-singlecellexperiment" ,r-singlecellexperiment)
+ ("r-summarizedexperiment" ,r-summarizedexperiment)))
+ (native-inputs `(("r-knitr" ,r-knitr)))
+ (home-page "https://bioconductor.org/packages/batchelor")
+ (synopsis "Single-Cell Batch Correction Methods")
+ (description
+ "This package implements a variety of methods for batch correction of
+single-cell (RNA sequencing) data. This includes methods based on detecting
+mutually nearest neighbors, as well as several efficient variants of linear
+regression of the log-expression values. Functions are also provided to
+perform global rescaling to remove differences in depth between batches, and
+to perform a principal components analysis that is robust to differences in
+the numbers of cells across batches.")
+ (license license:gpl3)))
+
(define-public r-mast
(package
(name "r-mast")