summaryrefslogtreecommitdiff
path: root/gnu/packages/bioconductor.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2021-06-21 17:51:27 +0200
committerRicardo Wurmus <rekado@elephly.net>2021-06-21 17:53:26 +0200
commit278e1c090e8b567169934de293649abf268eae53 (patch)
treed4c0ca3abbcbf0944cf4315be2fae364bf89e2b5 /gnu/packages/bioconductor.scm
parent111aa862ec204f619143ffc93c0c55560916b294 (diff)
downloadguix-patches-278e1c090e8b567169934de293649abf268eae53.tar
guix-patches-278e1c090e8b567169934de293649abf268eae53.tar.gz
gnu: Add r-residualmatrix.
* gnu/packages/bioconductor.scm (r-residualmatrix): New variable.
Diffstat (limited to 'gnu/packages/bioconductor.scm')
-rw-r--r--gnu/packages/bioconductor.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index 6845894e97..1d4a033038 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -6205,6 +6205,37 @@ classification (assignment) methods. It also contains a Shiny application for
interactive exploration of results.")
(license license:gpl2+)))
+(define-public r-residualmatrix
+ (package
+ (name "r-residualmatrix")
+ (version "1.2.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "ResidualMatrix" version))
+ (sha256
+ (base32
+ "0p7va19aw0j6anx7ck879kbi5cn7dy712h5ia94adr38ssismv1v"))))
+ (properties
+ `((upstream-name . "ResidualMatrix")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-delayedarray" ,r-delayedarray)
+ ("r-matrix" ,r-matrix)
+ ("r-s4vectors" ,r-s4vectors)))
+ (native-inputs
+ `(("r-knitr" ,r-knitr)))
+ (home-page "https://github.com/LTLA/ResidualMatrix")
+ (synopsis "Create a DelayedMatrix of regression residuals")
+ (description
+ "This package implements tools for delayed computation of a matrix of
+residuals after fitting a linear model to each column of an input matrix. It
+also supports partial computation of residuals where selected factors are to
+be preserved in the output matrix. It implements a number of efficient
+methods for operating on the delayed matrix of residuals, most notably matrix
+multiplication and calculation of row/column sums or means.")
+ (license license:gpl3)))
+
(define-public r-mast
(package
(name "r-mast")