summaryrefslogtreecommitdiff
path: root/gnu/packages/bash.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2016-09-30 16:59:51 +0200
committerLudovic Courtès <ludo@gnu.org>2016-10-01 00:00:02 +0200
commita7a1cf29485be66e606551ccfbcfcec4bc550791 (patch)
tree634b102e764a010286470f33e188cbf1c1ae0a3e /gnu/packages/bash.scm
parent0c64d8564f9a4a7f6d6c9e5013e25193c598332d (diff)
downloadguix-patches-a7a1cf29485be66e606551ccfbcfcec4bc550791.tar
guix-patches-a7a1cf29485be66e606551ccfbcfcec4bc550791.tar.gz
gnu: bash-static: Use 'modify-phases'.
* gnu/packages/bash.scm (static-bash)[arguments]: Use 'modify-phases'.
Diffstat (limited to 'gnu/packages/bash.scm')
-rw-r--r--gnu/packages/bash.scm19
1 files changed, 9 insertions, 10 deletions
diff --git a/gnu/packages/bash.scm b/gnu/packages/bash.scm
index bddb83046a..885e3cb226 100644
--- a/gnu/packages/bash.scm
+++ b/gnu/packages/bash.scm
@@ -261,16 +261,15 @@ without modification.")
(substitute-keyword-arguments
`(#:allowed-references ("out") ,@(package-arguments bash))
((#:phases phases)
- `(alist-cons-after
- 'strip 'remove-everything-but-the-binary
- (lambda* (#:key outputs #:allow-other-keys)
- (let* ((out (assoc-ref outputs "out"))
- (bin (string-append out "/bin")))
- (remove-store-references (string-append bin "/bash"))
- (delete-file (string-append bin "/bashbug"))
- (delete-file-recursively (string-append out "/share"))
- #t))
- ,phases)))))))
+ `(modify-phases ,phases
+ (add-after 'strip 'remove-everything-but-the-binary
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (bin (string-append out "/bin")))
+ (remove-store-references (string-append bin "/bash"))
+ (delete-file (string-append bin "/bashbug"))
+ (delete-file-recursively (string-append out "/share"))
+ #t))))))))))
(define-public bash-completion
(package