summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/bash.scm19
1 files changed, 9 insertions, 10 deletions
diff --git a/gnu/packages/bash.scm b/gnu/packages/bash.scm
index bddb83046a..885e3cb226 100644
--- a/gnu/packages/bash.scm
+++ b/gnu/packages/bash.scm
@@ -261,16 +261,15 @@ without modification.")
(substitute-keyword-arguments
`(#:allowed-references ("out") ,@(package-arguments bash))
((#:phases phases)
- `(alist-cons-after
- 'strip 'remove-everything-but-the-binary
- (lambda* (#:key outputs #:allow-other-keys)
- (let* ((out (assoc-ref outputs "out"))
- (bin (string-append out "/bin")))
- (remove-store-references (string-append bin "/bash"))
- (delete-file (string-append bin "/bashbug"))
- (delete-file-recursively (string-append out "/share"))
- #t))
- ,phases)))))))
+ `(modify-phases ,phases
+ (add-after 'strip 'remove-everything-but-the-binary
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (bin (string-append out "/bin")))
+ (remove-store-references (string-append bin "/bash"))
+ (delete-file (string-append bin "/bashbug"))
+ (delete-file-recursively (string-append out "/share"))
+ #t))))))))))
(define-public bash-completion
(package