summaryrefslogtreecommitdiff
path: root/gnu/packages/avahi.scm
diff options
context:
space:
mode:
authorMaxime Devos <maximedevos@telenet.be>2021-08-25 13:53:22 +0200
committerMathieu Othacehe <othacehe@gnu.org>2021-09-20 11:15:08 +0000
commit0636f02b0e33aed9b2f951bc91ded0fe8a7d1654 (patch)
tree3e64640ab941b7b76e43b2616665b4f00709d7ca /gnu/packages/avahi.scm
parent0515ebb0d17f4350b094cace66d5469640029da7 (diff)
downloadguix-patches-0636f02b0e33aed9b2f951bc91ded0fe8a7d1654.tar
guix-patches-0636f02b0e33aed9b2f951bc91ded0fe8a7d1654.tar.gz
gnu: avahi: Use the cross-compiled bash.
* gnu/packages/avahi.scm (avahi)[arguments]<#:phases>{patch-more-shebangs}: Replace the bash in the shebangs in "/etc/avahi" with a cross-compiled bash.
Diffstat (limited to 'gnu/packages/avahi.scm')
-rw-r--r--gnu/packages/avahi.scm25
1 files changed, 23 insertions, 2 deletions
diff --git a/gnu/packages/avahi.scm b/gnu/packages/avahi.scm
index 5582df479e..7dcaa17a76 100644
--- a/gnu/packages/avahi.scm
+++ b/gnu/packages/avahi.scm
@@ -23,9 +23,11 @@
(define-module (gnu packages avahi)
#:use-module ((guix licenses) #:select (lgpl2.1+))
#:use-module (guix packages)
+ #:use-module (guix gexp)
#:use-module (guix download)
#:use-module (guix build-system gnu)
#:use-module (gnu packages)
+ #:use-module (gnu packages bash)
#:use-module (gnu packages dbm)
#:use-module (gnu packages gettext)
#:use-module (gnu packages glib)
@@ -72,9 +74,28 @@
"--enable-compat-libdns_sd"
,@(if (%current-target-system)
'("ac_cv_prog_have_pkg_config=yes")
- '()))))
+ '()))
+ ;; TODO(core-updates): Make this unconditional.
+ ,@(if (%current-target-system)
+ `(#:modules ((srfi srfi-26)
+ (guix build utils)
+ (guix build gnu-build-system))
+ #:phases
+ ,#~(modify-phases %standard-phases
+ (add-after 'patch-shebangs 'patch-more-shebangs
+ (lambda* (#:key inputs #:allow-other-keys)
+ (define path
+ `(,(dirname (search-input-file inputs "bin/sh"))))
+ (for-each
+ (cut patch-shebang <> path)
+ (find-files (string-append #$output "/etc/avahi")))))))
+ '())))
(inputs
- `(("dbus" ,dbus)
+ ;; TODO(core-updates): Make this input unconditional.
+ `(,@(if (%current-target-system)
+ `(("bash-minimal" ,bash-minimal))
+ '())
+ ("dbus" ,dbus)
("expat" ,expat)
("gdbm" ,gdbm)
("glib" ,glib)