summaryrefslogtreecommitdiff
path: root/gnu/packages/avahi.scm
diff options
context:
space:
mode:
authorMaxime Devos <maximedevos@telenet.be>2021-08-25 12:42:23 +0200
committerMathieu Othacehe <othacehe@gnu.org>2021-09-20 11:15:08 +0000
commit0515ebb0d17f4350b094cace66d5469640029da7 (patch)
tree9533bc6f9b37a965b00306b19c583a03137252ff /gnu/packages/avahi.scm
parent35e1a572f6424c4d9bd2679590be14d664dd2121 (diff)
downloadguix-patches-0515ebb0d17f4350b094cace66d5469640029da7.tar
guix-patches-0515ebb0d17f4350b094cace66d5469640029da7.tar.gz
gnu: avahi: Find 'TARGET-pkg-config' when cross-compiling.
The configure script first tests whether "pkg-config" is in PATH, and then uses "TARGET-pkg-config". Pretend "pkg-config" exists. * gnu/packages/avahi.scm (avah)[arguments]<#:configure-flags>: Set ac_cv_prog_have_pkg_config=yes when cross-compiling.
Diffstat (limited to 'gnu/packages/avahi.scm')
-rw-r--r--gnu/packages/avahi.scm8
1 files changed, 6 insertions, 2 deletions
diff --git a/gnu/packages/avahi.scm b/gnu/packages/avahi.scm
index 602f9d7997..5582df479e 100644
--- a/gnu/packages/avahi.scm
+++ b/gnu/packages/avahi.scm
@@ -3,6 +3,7 @@
;;; Copyright © 2014 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2020 Marius Bakke <mbakke@fastmail.com>
+;;; Copyright © 2021 Maxime Devos <maximedevos@telenet.be>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -58,7 +59,7 @@
#t))))
(build-system gnu-build-system)
(arguments
- '(#:configure-flags '("--with-distro=none"
+ `(#:configure-flags '("--with-distro=none"
"--disable-static"
"--localstatedir=/var" ; for the DBus socket
"--disable-python"
@@ -68,7 +69,10 @@
"--enable-tests"
"--disable-qt4" "--disable-qt5"
"--disable-gtk" "--disable-gtk3"
- "--enable-compat-libdns_sd")))
+ "--enable-compat-libdns_sd"
+ ,@(if (%current-target-system)
+ '("ac_cv_prog_have_pkg_config=yes")
+ '()))))
(inputs
`(("dbus" ,dbus)
("expat" ,expat)