summaryrefslogtreecommitdiff
path: root/gnu/packages/autotools.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2017-01-04 19:44:27 -0500
committerLeo Famulari <leo@famulari.name>2017-01-05 10:43:17 -0500
commitc5862bda95e3171c1addf6ff198a953bcda785b4 (patch)
treeb420e60cfd1a5e74a79cf0c12bb086f41c9dd6fa /gnu/packages/autotools.scm
parent98341757c8c45fca8d2b53f9972f5c6a32cf2c95 (diff)
downloadguix-patches-c5862bda95e3171c1addf6ff198a953bcda785b4.tar
guix-patches-c5862bda95e3171c1addf6ff198a953bcda785b4.tar.gz
gnu: libtool: Don't replace 'sh' reference with 'bash'.
Bash behaves differently based on how it is invoked (see Invocation in bash(1)). * gnu/packages/autotools.scm (libtool)[arguments]: Use /bin/sh instead of /bin/bash in 'pre-check' phase. Fix typo in comment.
Diffstat (limited to 'gnu/packages/autotools.scm')
-rw-r--r--gnu/packages/autotools.scm4
1 files changed, 2 insertions, 2 deletions
diff --git a/gnu/packages/autotools.scm b/gnu/packages/autotools.scm
index 83018ca8ff..8ff7b8cf6d 100644
--- a/gnu/packages/autotools.scm
+++ b/gnu/packages/autotools.scm
@@ -325,11 +325,11 @@ Makefile, simplifying the entire process for the developer.")
(string-append
"-j"
(number->string (parallel-job-count))))
- ;; Path references to /bin/sh.
+ ;; Patch references to /bin/sh.
(let ((bash (assoc-ref inputs "bash")))
(substitute* "tests/testsuite"
(("/bin/sh")
- (string-append bash "/bin/bash")))))))))
+ (string-append bash "/bin/sh"))))))
(add-after 'patch-source-shebangs 'restore-ltmain-shebang
(lambda* (#:key inputs #:allow-other-keys)
(substitute* "build-aux/ltmain.in"