summaryrefslogtreecommitdiff
path: root/gnu/packages/algebra.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2020-02-16 09:06:53 +0200
committerEfraim Flashner <efraim@flashner.co.il>2020-02-16 09:19:06 +0200
commit778d6b522ae361767d3cf984a3b182bac7361b7a (patch)
treef613550262043334df156b37f3598dc7e2d7d618 /gnu/packages/algebra.scm
parent481a0f1a7ceac666a011b28324220584ead07698 (diff)
downloadguix-patches-778d6b522ae361767d3cf984a3b182bac7361b7a.tar
guix-patches-778d6b522ae361767d3cf984a3b182bac7361b7a.tar.gz
gnu: Remove obsolete bootstrap workaround phases.
* gnu/packages/admin.scm (igt-gpu-tools)[arguments]: Don't set NOCONFIGURE environment variable. * gnu/packages/algebra.scm (givaro, fflas-ffpack, linbox), * gnu/packages/arcan.scm (xarcan), * gnu/packages/audio.scm (rtmidi), * gnu/packages/cinnamon.scm (cinnamon-desktop), * gnu/packages/gnome.scm (dia, libxklavier, byzanz), * gnu/packages/image-viewers.scm (geeqie), * gnu/packages/libusb.scm (libplist), * gnu/packages/mail.scm (libetpan), * gnu/packages/networking.scm (aircrack-ng), * gnu/packages/terminals.scm (tilda, kmscon), * gnu/packages/xorg.scm (xf86-video-intel, xcompmgr) [arguments]: Same.
Diffstat (limited to 'gnu/packages/algebra.scm')
-rw-r--r--gnu/packages/algebra.scm28
1 files changed, 1 insertions, 27 deletions
diff --git a/gnu/packages/algebra.scm b/gnu/packages/algebra.scm
index d3e4dfbd86..08d209ec58 100644
--- a/gnu/packages/algebra.scm
+++ b/gnu/packages/algebra.scm
@@ -1217,15 +1217,6 @@ objects.")
("libtool" ,libtool)))
(propagated-inputs
`(("gmp" ,gmp))) ; gmp++.h includes gmpxx.h
- (arguments
- `(#:phases
- (modify-phases %standard-phases
- (add-before 'bootstrap 'setenv
- ;; Prevent the autogen.sh script to carry out the configure
- ;; script, which has not yet been patched to replace /bin/sh.
- (lambda _
- (setenv "NOCONFIGURE" "yes")
- #t)))))
(synopsis "Algebraic computations with exact rings and fields")
(description
"Givaro is a C++ library implementing the basic arithmetic of various
@@ -1264,15 +1255,7 @@ compound objects, such as vectors, matrices and univariate polynomials.")
`(#:configure-flags
(list (string-append "--with-blas-libs="
(assoc-ref %build-inputs "openblas")
- "/lib/libopenblas.so"))
- #:phases
- (modify-phases %standard-phases
- (add-before 'bootstrap 'setenv
- ;; Prevent the autogen.sh script to carry out the configure
- ;; script, which has not yet been patched to replace /bin/sh.
- (lambda _
- (setenv "NOCONFIGURE" "yes")
- #t)))))
+ "/lib/libopenblas.so"))))
(synopsis "C++ library for linear algebra over finite fields")
(description
"FFLAS-FFPACK is a C++ template library for basic linear algebra
@@ -1308,15 +1291,6 @@ algebra, such as the row echelon form.")
("pkg-config" ,pkg-config)))
(inputs
`(("fflas-ffpack" ,fflas-ffpack)))
- (arguments
- `(#:phases
- (modify-phases %standard-phases
- (add-before 'bootstrap 'setenv
- ;; Prevent the autogen.sh script to carry out the configure
- ;; script, which has not yet been patched to replace /bin/sh.
- (lambda _
- (setenv "NOCONFIGURE" "yes")
- #t)))))
(synopsis "C++ library for linear algebra over exact rings")
(description
"LinBox is a C++ template library for exact linear algebra computation