summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2020-02-16 09:06:53 +0200
committerEfraim Flashner <efraim@flashner.co.il>2020-02-16 09:19:06 +0200
commit778d6b522ae361767d3cf984a3b182bac7361b7a (patch)
treef613550262043334df156b37f3598dc7e2d7d618 /gnu/packages
parent481a0f1a7ceac666a011b28324220584ead07698 (diff)
downloadguix-patches-778d6b522ae361767d3cf984a3b182bac7361b7a.tar
guix-patches-778d6b522ae361767d3cf984a3b182bac7361b7a.tar.gz
gnu: Remove obsolete bootstrap workaround phases.
* gnu/packages/admin.scm (igt-gpu-tools)[arguments]: Don't set NOCONFIGURE environment variable. * gnu/packages/algebra.scm (givaro, fflas-ffpack, linbox), * gnu/packages/arcan.scm (xarcan), * gnu/packages/audio.scm (rtmidi), * gnu/packages/cinnamon.scm (cinnamon-desktop), * gnu/packages/gnome.scm (dia, libxklavier, byzanz), * gnu/packages/image-viewers.scm (geeqie), * gnu/packages/libusb.scm (libplist), * gnu/packages/mail.scm (libetpan), * gnu/packages/networking.scm (aircrack-ng), * gnu/packages/terminals.scm (tilda, kmscon), * gnu/packages/xorg.scm (xf86-video-intel, xcompmgr) [arguments]: Same.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/admin.scm9
-rw-r--r--gnu/packages/algebra.scm28
-rw-r--r--gnu/packages/arcan.scm8
-rw-r--r--gnu/packages/audio.scm7
-rw-r--r--gnu/packages/cinnamon.scm7
-rw-r--r--gnu/packages/gnome.scm23
-rw-r--r--gnu/packages/image-viewers.scm1
-rw-r--r--gnu/packages/libusb.scm9
-rw-r--r--gnu/packages/mail.scm8
-rw-r--r--gnu/packages/networking.scm6
-rw-r--r--gnu/packages/terminals.scm10
-rw-r--r--gnu/packages/xorg.scm14
12 files changed, 9 insertions, 121 deletions
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index af39676d57..02fdb453b6 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -2802,14 +2802,7 @@ buffers.")
(base32 "1gpdjs5aj6vsnzwcjvw5bb120lgffvvshi4202phr0bzw3b92ky8"))))
(build-system gnu-build-system)
(arguments
- `(#:tests? #f ; many of the tests try to load kernel modules
- #:phases
- (modify-phases %standard-phases
- (replace 'bootstrap
- (lambda _
- ;; Don't run configure in this phase.
- (setenv "NOCONFIGURE" "1")
- (invoke "sh" "autogen.sh"))))))
+ `(#:tests? #f)) ; many of the tests try to load kernel modules
(inputs
`(("cairo" ,cairo)
("elfutils" ,elfutils) ; libdw
diff --git a/gnu/packages/algebra.scm b/gnu/packages/algebra.scm
index d3e4dfbd86..08d209ec58 100644
--- a/gnu/packages/algebra.scm
+++ b/gnu/packages/algebra.scm
@@ -1217,15 +1217,6 @@ objects.")
("libtool" ,libtool)))
(propagated-inputs
`(("gmp" ,gmp))) ; gmp++.h includes gmpxx.h
- (arguments
- `(#:phases
- (modify-phases %standard-phases
- (add-before 'bootstrap 'setenv
- ;; Prevent the autogen.sh script to carry out the configure
- ;; script, which has not yet been patched to replace /bin/sh.
- (lambda _
- (setenv "NOCONFIGURE" "yes")
- #t)))))
(synopsis "Algebraic computations with exact rings and fields")
(description
"Givaro is a C++ library implementing the basic arithmetic of various
@@ -1264,15 +1255,7 @@ compound objects, such as vectors, matrices and univariate polynomials.")
`(#:configure-flags
(list (string-append "--with-blas-libs="
(assoc-ref %build-inputs "openblas")
- "/lib/libopenblas.so"))
- #:phases
- (modify-phases %standard-phases
- (add-before 'bootstrap 'setenv
- ;; Prevent the autogen.sh script to carry out the configure
- ;; script, which has not yet been patched to replace /bin/sh.
- (lambda _
- (setenv "NOCONFIGURE" "yes")
- #t)))))
+ "/lib/libopenblas.so"))))
(synopsis "C++ library for linear algebra over finite fields")
(description
"FFLAS-FFPACK is a C++ template library for basic linear algebra
@@ -1308,15 +1291,6 @@ algebra, such as the row echelon form.")
("pkg-config" ,pkg-config)))
(inputs
`(("fflas-ffpack" ,fflas-ffpack)))
- (arguments
- `(#:phases
- (modify-phases %standard-phases
- (add-before 'bootstrap 'setenv
- ;; Prevent the autogen.sh script to carry out the configure
- ;; script, which has not yet been patched to replace /bin/sh.
- (lambda _
- (setenv "NOCONFIGURE" "yes")
- #t)))))
(synopsis "C++ library for linear algebra over exact rings")
(description
"LinBox is a C++ template library for exact linear algebra computation
diff --git a/gnu/packages/arcan.scm b/gnu/packages/arcan.scm
index db472efec5..e3f8b60aea 100644
--- a/gnu/packages/arcan.scm
+++ b/gnu/packages/arcan.scm
@@ -216,13 +216,7 @@ engine programmable using Lua.")
(assoc-ref %build-inputs "xkbcomp")
"/bin")
,(string-append "--with-xkb-output="
- "/tmp")) ; FIXME: Copied from xorg
- #:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'noconfigure
- (lambda _
- (setenv "NOCONFIGURE" "true")
- #t)))))
+ "/tmp")))) ; FIXME: Copied from xorg
(native-inputs
`(("pkg-config" ,pkg-config)
("autoconf" ,autoconf)
diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index fbb2d90979..78d29e1c68 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -2444,13 +2444,6 @@ tempo and pitch of an audio recording independently of one another.")
(base32
"1k962ljpnwyjw9jjiky2372khhri1wqvrj5qsalfpys31xqzw31p"))))
(build-system gnu-build-system)
- (arguments
- `(#:phases
- (modify-phases %standard-phases
- (add-before 'bootstrap 'noconfigure
- (lambda _
- (setenv "NOCONFIGURE" "yes")
- #t)))))
(inputs
`(("jack" ,jack-1)
("alsa-lib" ,alsa-lib)))
diff --git a/gnu/packages/cinnamon.scm b/gnu/packages/cinnamon.scm
index a8850391aa..fadf18df81 100644
--- a/gnu/packages/cinnamon.scm
+++ b/gnu/packages/cinnamon.scm
@@ -51,13 +51,6 @@
(base32
"18mjy80ly9361npjhxpm3n0pkmrwviaqr2kixjb7hyxa6kzzh5xw"))))
(build-system gnu-build-system)
- (arguments
- `(#:phases
- (modify-phases %standard-phases
- (add-before 'bootstrap 'skip-premature-configure
- (lambda _
- (setenv "NOCONFIGURE" "set")
- #t)))))
;; TODO: package 'libgsystem'.
(inputs
`(("accountsservice" ,accountsservice)
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index cc00b69cf3..d9a5e6fe5b 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -911,13 +911,6 @@ useful as a tutorial and users' guide for new or less experienced users.")
("perl" ,perl)
("pkg-config" ,pkg-config)
("python-wrapper" ,python-wrapper)))
- (arguments
- `(#:phases
- (modify-phases %standard-phases
- (add-before 'bootstrap 'dont-configure-during-bootstrap
- (lambda _
- (setenv "NOCONFIGURE" "true")
- #t)))))
(home-page "https://wiki.gnome.org/Apps/Dia")
(synopsis "Diagram creation for GNOME")
(description "Dia can be used to draw different types of diagrams, and
@@ -3505,13 +3498,7 @@ and objects.")
(file-name (git-file-name name version))))
(build-system gnu-build-system)
(arguments
- '(#:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'no-configure
- (lambda* _
- (setenv "NOCONFIGURE" "1")
- #t)))
- #:configure-flags
+ '(#:configure-flags
(list (string-append "--with-xkb-base="
(assoc-ref %build-inputs "xkeyboard-config")
"/share/X11/xkb")
@@ -7924,7 +7911,7 @@ documents and diagrams, playing media, scanning, and much more.")
(arguments
'(#:phases
(modify-phases %standard-phases
- (replace 'bootstrap
+ (add-before 'bootstrap 'build-without-Werror
(lambda _
;; The build system cleverly detects that we're not building from
;; a release tarball and turns on -Werror for GCC.
@@ -7932,11 +7919,7 @@ documents and diagrams, playing media, scanning, and much more.")
;; causes the build to fail unnecessarily, so we remove the flag.
(substitute* '("configure.ac")
(("-Werror") ""))
- ;; The autogen.sh script in gnome-common will run ./configure
- ;; by default, which is problematic because source shebangs
- ;; have not yet been patched.
- (setenv "NOCONFIGURE" "t")
- (zero? (system* "sh" "autogen.sh")))))))
+ #t)))))
(native-inputs
`(("autoconf" ,autoconf)
("automake" ,automake)
diff --git a/gnu/packages/image-viewers.scm b/gnu/packages/image-viewers.scm
index 8589130822..2ac15a6cd9 100644
--- a/gnu/packages/image-viewers.scm
+++ b/gnu/packages/image-viewers.scm
@@ -155,7 +155,6 @@ actions.")
write-dummy-changelog)
(call-with-output-file "ChangeLog.html"
write-dummy-changelog)
- (setenv "NOCONFIGURE" "true")
;; Don't try to run 'git' for the version number.
(substitute* "configure.ac"
diff --git a/gnu/packages/libusb.scm b/gnu/packages/libusb.scm
index 5e468a4316..a0ae273b67 100644
--- a/gnu/packages/libusb.scm
+++ b/gnu/packages/libusb.scm
@@ -318,14 +318,7 @@ wrapper for accessing libusb-1.0.")
(base32 "02vraf4j46bp746s0gz7vga2gv2dy3zd1v1bsy9x8algg9fpcb7n"))))
(build-system gnu-build-system)
(arguments
- `(#:phases
- (modify-phases %standard-phases
- (add-before 'bootstrap 'configure-later
- ;; Don't run ./configure during bootstrap.
- (lambda _
- (setenv "NOCONFIGURE" "set")
- #t)))
- ;; Tests fail randomly when run in parallel because several of them write
+ `(;; Tests fail randomly when run in parallel because several of them write
;; and read to/from the same file--e.g., "4.plist" is accessed by
;; 'large.test' and 'largecmp.test'.
#:parallel-tests? #f))
diff --git a/gnu/packages/mail.scm b/gnu/packages/mail.scm
index 1a9f9e5e5c..9d6e3dba8b 100644
--- a/gnu/packages/mail.scm
+++ b/gnu/packages/mail.scm
@@ -1133,13 +1133,7 @@ useful features.")
("expat" ,expat)
("zlib" ,zlib)))
(arguments
- '(#:phases
- (modify-phases %standard-phases
- (replace 'bootstrap
- (lambda _
- (setenv "NOCONFIGURE" "true")
- (invoke "sh" "autogen.sh"))))
- #:configure-flags
+ '(#:configure-flags
'("--disable-static" "--disable-db")))
(home-page "https://www.etpan.org/libetpan.html")
(synopsis "Portable middleware for email access")
diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index dbc40028ad..4a48355163 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -934,12 +934,6 @@ live network and disk I/O bandwidth monitor.")
(("/bin/sh")
(which "sh")))
#t))
- (replace 'bootstrap
- (lambda _
- ;; Patch shebangs in generated files before running
- ;; ./configure.
- (setenv "NOCONFIGURE" "please")
- (invoke "bash" "./autogen.sh")))
(add-after 'build 'absolutize-tools
(lambda* (#:key inputs #:allow-other-keys)
(let ((ethtool (string-append (assoc-ref inputs "ethtool")
diff --git a/gnu/packages/terminals.scm b/gnu/packages/terminals.scm
index 8773f1969f..cffaea24a0 100644
--- a/gnu/packages/terminals.scm
+++ b/gnu/packages/terminals.scm
@@ -96,12 +96,6 @@
(base32
"154rsldqjv2m1bddisb930qicb0y35kx7bxq392n2hn68jr2pxkj"))))
(build-system glib-or-gtk-build-system)
- (arguments
- '(#:phases (modify-phases %standard-phases
- (replace 'bootstrap
- (lambda _
- (setenv "NOCONFIGURE" "true")
- (invoke "sh" "autogen.sh"))))))
(native-inputs
`(("autoconf" ,autoconf)
("automake" ,automake)
@@ -276,10 +270,6 @@ compatibility to existing emulators like xterm, gnome-terminal, konsole, etc.")
#:disallowed-references (,mesa)
#:phases (modify-phases %standard-phases
- (replace 'bootstrap
- (lambda _
- (setenv "NOCONFIGURE" "indeed")
- (invoke "sh" "autogen.sh")))
;; Use elogind instead of systemd.
(add-before 'configure 'remove-systemd
(lambda _
diff --git a/gnu/packages/xorg.scm b/gnu/packages/xorg.scm
index ab86b228bb..3fb2cf8d0f 100644
--- a/gnu/packages/xorg.scm
+++ b/gnu/packages/xorg.scm
@@ -2980,13 +2980,7 @@ X server.")
(string-prefix? "x86_64-" system)))
%supported-systems))
(arguments
- '(#:configure-flags '("--with-default-accel=uxa")
- #:phases (modify-phases %standard-phases
- (add-before 'bootstrap 'pre-bootstrap
- (lambda _
- ;; Inhibit autogen.sh from running configure.
- (setenv "NOCONFIGURE" "1")
- #t)))))
+ '(#:configure-flags '("--with-default-accel=uxa")))
(home-page "https://www.x.org/wiki/")
(synopsis "Intel video driver for X server")
(description
@@ -6079,12 +6073,6 @@ Conventions Manual) and some of the @dfn{EWMH}
(base32 "11i7vyk3pynw8q8aczpy56qncm84y0cmhlvyja3sj8dgy60g03q2"))
(file-name (git-file-name name version))))
(build-system gnu-build-system)
- (arguments
- `(#:phases (modify-phases %standard-phases
- (add-after 'unpack 'autogen
- (lambda _
- (setenv "NOCONFIGURE" "t")
- (invoke "sh" "autogen.sh"))))))
(native-inputs
`(("pkg-config" ,pkg-config)
("autoconf" ,autoconf)