summaryrefslogtreecommitdiff
path: root/gnu/packages/algebra.scm
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2019-06-20 11:45:04 +0200
committerAndreas Enge <andreas@enge.fr>2019-06-20 12:21:04 +0200
commit66c67e7ba1b468dc3874fb9c84997992b7737181 (patch)
tree508b58252f23c700321cfc5702970b7d6ad37b56 /gnu/packages/algebra.scm
parent6cbedbd2f25f7e4da057d226e0fa2ac21e2577b1 (diff)
downloadguix-patches-66c67e7ba1b468dc3874fb9c84997992b7737181.tar
guix-patches-66c67e7ba1b468dc3874fb9c84997992b7737181.tar.gz
gnu: Add eclib.
* gnu/packages/algebra.scm (eclib): New variable.
Diffstat (limited to 'gnu/packages/algebra.scm')
-rw-r--r--gnu/packages/algebra.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/algebra.scm b/gnu/packages/algebra.scm
index c1cbaca311..810e9ce12a 100644
--- a/gnu/packages/algebra.scm
+++ b/gnu/packages/algebra.scm
@@ -1460,3 +1460,33 @@ over finite fields of characteristic 2. So it extends the functionality
of M4RI from F_2 to F_{2^e}.")
(license license:gpl2+)
(home-page "https://bitbucket.org/malb/m4rie/")))
+
+(define-public eclib
+ (package
+ (name "eclib")
+ (version "20190226")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/JohnCremona/eclib/")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1910np1xzyjzszay24xn4b81qhpsvhp5aix9vdpknplni2mq8kwb"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("autoconf" ,autoconf)
+ ("automake" ,automake)
+ ("libtool" ,libtool)))
+ (inputs
+ `(("gmp" ,gmp)
+ ("ntl" ,ntl)
+ ("pari-gp" ,pari-gp)))
+ (synopsis "Ranks of elliptic curves and modular symbols")
+ (description "The eclib package includes mwrank (for 2-descent on
+elliptic curves over Q) and modular symbol code; it has been written by
+John Cremona to compute his elliptic curve database.")
+ (license license:gpl2+)
+ (home-page (string-append "http://homepages.warwick.ac.uk/staff/"
+ "J.E.Cremona/mwrank/index.html"))))