summaryrefslogtreecommitdiff
path: root/gnu/packages/algebra.scm
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2019-06-20 11:15:37 +0200
committerAndreas Enge <andreas@enge.fr>2019-06-20 12:20:11 +0200
commit6cbedbd2f25f7e4da057d226e0fa2ac21e2577b1 (patch)
treeb2f0cb7dc19d0fe5994c0d0ca967e1a3d20bbb13 /gnu/packages/algebra.scm
parent9553a41dbee956aeece7631321fc52a264311541 (diff)
downloadguix-patches-6cbedbd2f25f7e4da057d226e0fa2ac21e2577b1.tar
guix-patches-6cbedbd2f25f7e4da057d226e0fa2ac21e2577b1.tar.gz
gnu: Add m4rie.
* gnu/packages/algebra.scm (m4rie): New variable.
Diffstat (limited to 'gnu/packages/algebra.scm')
-rw-r--r--gnu/packages/algebra.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/algebra.scm b/gnu/packages/algebra.scm
index 22d458d36d..c1cbaca311 100644
--- a/gnu/packages/algebra.scm
+++ b/gnu/packages/algebra.scm
@@ -1433,3 +1433,30 @@ for the representation theory of the symmetric group and related groups,
combinatorics of tableaux, symmetric functions and polynomials, Schubert
polynomials, and the representation theory of Hecke algebras of type A_n.")
(license license:public-domain)))
+
+(define-public m4rie
+ (package
+ (name "m4rie")
+ (version "20150908")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://bitbucket.org/malb/m4rie")
+ (commit (string-append "release-" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0r8lv46qx5mkz5kp3ay2jnsp0mbhlqr5z2z220wdk73wdshcznss"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("autoconf" ,autoconf)
+ ("automake" ,automake)
+ ("libtool" ,libtool)))
+ (inputs
+ `(("m4ri" ,m4ri)))
+ (synopsis "Arithmetic of dense matrices over F_{2^e}")
+ (description "M4RI is a library for fast arithmetic with dense matrices
+over finite fields of characteristic 2. So it extends the functionality
+of M4RI from F_2 to F_{2^e}.")
+ (license license:gpl2+)
+ (home-page "https://bitbucket.org/malb/m4rie/")))