summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWamm K. D <jaft.r@outlook.com>2022-04-20 13:18:25 -0500
committerLudovic Courtès <ludo@gnu.org>2022-04-27 23:18:37 +0200
commitff12cf5e0702757661f870b2679a4c5fecc714b9 (patch)
tree3e3bfb70c51609037f4e727ed016eb47bcdd7f10
parent7ed87432e3c8f8192cf45133d5b572c034576ca5 (diff)
downloadguix-patches-ff12cf5e0702757661f870b2679a4c5fecc714b9.tar
guix-patches-ff12cf5e0702757661f870b2679a4c5fecc714b9.tar.gz
gnu: Add hyfetch.
* gnu/packages/admin.scm (hyfetch): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/admin.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index 94636faf8b..a200050d97 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -47,6 +47,7 @@
;;; Copyright © 2021 Maxime Devos <maximedevos@telenet.be>
;;; Copyright © 2021 Petr Hodina <phodina@protonmail.com>
;;; Copyright © 2021 Artyom V. Poptsov <poptsov.artyom@gmail.com>
+;;; Copyright © 2022 Wamm K. D. <jaft.r@outlook.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -3733,6 +3734,32 @@ used in screenshots to show other users what operating system or distribution
you are running, what theme or icon set you are using, etc.")
(license license:expat)))
+(define-public hyfetch
+ (package
+ (name "hyfetch")
+ (version "1.0.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "HyFetch" version))
+ (sha256
+ (base32 "1bfkycdhsyzkk6q24gdy1xwvyz0rvkr7xk2khbn74b3nk6kp83r2"))))
+ (build-system python-build-system)
+ (inputs (list python-hypy-utils python-typing-extensions))
+ (arguments `(#:phases (modify-phases %standard-phases
+ (add-before 'build 'set-HOME
+ (lambda _ ;; Tries to set files in .config
+ (setenv "HOME" "/tmp"))))))
+ (home-page "https://github.com/hykilpikonna/HyFetch")
+ (synopsis "@code{neofetch} with pride flags <3")
+ (description "HyFetch is a command-line system information tool fork of
+@code{neofetch}. HyFetch displays information about your system next to your
+OS logo in ASCII representation. The ASCII representation is then colored in
+the pattern of the pride flag of your choice. The main purpose of HyFetch is to
+be used in screenshots to show other users what operating system or distribution
+you are running, what theme or icon set you are using, etc.")
+ (license license:expat)))
+
(define-public screenfetch
(package
(name "screenfetch")