summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWamm K. D <jaft.r@outlook.com>2022-04-20 13:15:03 -0500
committerLudovic Courtès <ludo@gnu.org>2022-04-27 23:15:51 +0200
commit7ed87432e3c8f8192cf45133d5b572c034576ca5 (patch)
treea0788b93d885b0f099ddcb81400cb082485a39c0
parent31c9f0e30108bc9845df85e9b3f440d53b002409 (diff)
downloadguix-patches-7ed87432e3c8f8192cf45133d5b572c034576ca5.tar
guix-patches-7ed87432e3c8f8192cf45133d5b572c034576ca5.tar.gz
gnu: Add python-hypy-utils.
* gnu/packages/python-xyz.scm (python-hypy-utils): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/python-xyz.scm18
1 files changed, 18 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index a3a8734cbd..afb80171a5 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -119,6 +119,7 @@
;;; Copyright © 2022 Evgeny Pisemsky <evgeny@pisemsky.com>
;;; Copyright © 2022 drozdov <drozdov@portalenergy.tech>
;;; Copyright © 2022 Peter Polidoro <peter@polidoro.io>
+;;; Copyright © 2022 Wamm K. D. <jaft.r@outlook.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -29535,6 +29536,23 @@ uses the parsed regular expression, so you get a much more accurate result
than trying to just split strings.")
(license license:asl2.0)))
+(define-public python-hypy-utils
+ (package
+ (name "python-hypy-utils")
+ (version "1.0.6")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "hypy_utils" version))
+ (sha256
+ (base32
+ "05csk0x8ivavq88x457cq5hwjcdirfbkzj7bbg5qgnpnf2dxxhiw"))))
+ (build-system python-build-system)
+ (home-page "https://github.com/hykilpikonna/HyPyUtils")
+ (synopsis "Python utility functions for HyDEV")
+ (description "This module provides Python utility functions for modifying
+and setting the color of terminal output, via HyDEV.")
+ (license license:expat)))
+
(define-public python-mike
(package
(name "python-mike")