summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2016-09-11 15:07:36 +0100
committerLeo Famulari <leo@famulari.name>2016-09-14 20:56:02 -0400
commitdf94a6b57d0e507ca9a03257881445a35310c082 (patch)
treead305fe21ac62832d5264ca01fe2697b1eb0c68f
parent66f95b209af77d8d97cfeed75d363ad744500472 (diff)
downloadguix-patches-df94a6b57d0e507ca9a03257881445a35310c082.tar
guix-patches-df94a6b57d0e507ca9a03257881445a35310c082.tar.gz
gnu: Add python-pytest-flakes.
* gnu/packages/python.scm (python-pytest-flakes, python2-pytest-flakes): New variables. Signed-off-by: Leo Famulari <leo@famulari.name>
-rw-r--r--gnu/packages/python.scm41
1 files changed, 41 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 8ca7185ef4..8c61736a46 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -10385,3 +10385,44 @@ failures.")
(native-inputs
`(("python2-setuptools" ,python2-setuptools)
,@(package-native-inputs base))))))
+
+(define-public python-pytest-flakes
+ (package
+ (name "python-pytest-flakes")
+ (version "1.0.1")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "pytest-flakes" version))
+ (sha256
+ (base32
+ "0flag3n33kbhyjrhzmq990rvg4yb8hhhl0i48q9hw0ll89jp28lw"))))
+ (build-system python-build-system)
+ (arguments
+ `(;; Prevent creation of the egg. This works around
+ ;; https://debbugs.gnu.org/cgi/bugreport.cgi?bug=20765 .
+ #:configure-flags '("--single-version-externally-managed" "--root=/")
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'check)
+ (add-after 'install 'check
+ (lambda _ ; It's easier to run tests after install.
+ (zero? (system* "py.test" "-vv")))))))
+ (native-inputs
+ `(("python-coverage" ,python-coverage)
+ ("python-pytest" ,python-pytest)
+ ("python-pytest-cache" ,python-pytest-cache)
+ ("python-pytest-pep8" ,python-pytest-pep8)))
+ (propagated-inputs
+ `(("python-pyflakes" ,python-pyflakes)))
+ (home-page "https://github.com/fschulze/pytest-flakes")
+ (synopsis "Py.test plugin to check source code with pyflakes")
+ (description "Pytest plugin for checking Python source code with pyflakes.")
+ (license license:expat)
+ (properties `((python2-variant . ,(delay python2-pytest-flakes))))))
+
+(define-public python2-pytest-flakes
+ (let ((base (package-with-python2 (strip-python2-variant python-pytest-flakes))))
+ (package (inherit base)
+ (native-inputs
+ `(("python2-setuptools" ,python2-setuptools)
+ ,@(package-native-inputs base))))))