summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2016-09-11 15:07:35 +0100
committerLeo Famulari <leo@famulari.name>2016-09-14 20:55:58 -0400
commit66f95b209af77d8d97cfeed75d363ad744500472 (patch)
tree2297728523e87c7ec867a0880ce5f0ec5dd81c22
parent74c0282c4591720b9a81359e400bb460718b78c1 (diff)
downloadguix-patches-66f95b209af77d8d97cfeed75d363ad744500472.tar
guix-patches-66f95b209af77d8d97cfeed75d363ad744500472.tar.gz
gnu: Add python-pytest-pep8.
* gnu/packages/python.scm (python-pytest-pep8, python2-pytest-pep8): New variables. Signed-off-by: Leo Famulari <leo@famulari.name>
-rw-r--r--gnu/packages/python.scm33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index e2e1ec2ee8..8ca7185ef4 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -10352,3 +10352,36 @@ failures.")
(native-inputs
`(("python2-setuptools" ,python2-setuptools)
,@(package-native-inputs base))))))
+
+(define-public python-pytest-pep8
+ (package
+ (name "python-pytest-pep8")
+ (version "1.0.6")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "pytest-pep8" version))
+ (sha256
+ (base32
+ "06032agzhw1i9d9qlhfblnl3dw5hcyxhagn7b120zhrszbjzfbh3"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:tests? #f ; Fails with recent pytest and pep8. See upstream issues #8 and #12.
+ ;; Prevent creation of the egg. This works around
+ ;; https://debbugs.gnu.org/cgi/bugreport.cgi?bug=20765 .
+ #:configure-flags '("--single-version-externally-managed" "--root=/")))
+ (native-inputs
+ `(("python-pytest" ,python-pytest)))
+ (propagated-inputs
+ `(("python-pep8" ,python-pep8)))
+ (home-page "https://bitbucket.org/pytest-dev/pytest-pep8")
+ (synopsis "Py.test plugin to check PEP8 requirements")
+ (description "Pytest plugin for checking PEP8 compliance.")
+ (license license:expat)
+ (properties `((python2-variant . ,(delay python2-pytest-pep8))))))
+
+(define-public python2-pytest-pep8
+ (let ((base (package-with-python2 (strip-python2-variant python-pytest-pep8))))
+ (package (inherit base)
+ (native-inputs
+ `(("python2-setuptools" ,python2-setuptools)
+ ,@(package-native-inputs base))))))