summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn Soo <jsoo1@asu.edu>2020-06-16 20:43:55 -0700
committerEfraim Flashner <efraim@flashner.co.il>2020-07-09 17:00:21 +0300
commitcb123dad5e36b208572ea5acfcaa93c201215e4d (patch)
treeff231f47f86d23f140f3144f267f03e2e4056f67
parent39662c9ddcb5770d578d64721da798297b5934a0 (diff)
downloadguix-patches-cb123dad5e36b208572ea5acfcaa93c201215e4d.tar
guix-patches-cb123dad5e36b208572ea5acfcaa93c201215e4d.tar.gz
gnu: Add rust-rustc-rayon-core-0.3.
* gnu/packages/crates-io.scm (rust-rustc-rayon-core-0.3): New variable. Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
-rw-r--r--gnu/packages/crates-io.scm36
1 files changed, 36 insertions, 0 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index aea5ebed9a..1dad5d1608 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -20353,6 +20353,42 @@ It is automatically published using the compiler repository at
"This package provides a speedy, non-cryptographic hash used in rustc.")
(license (list license:asl2.0 license:expat))))
+(define-public rust-rustc-rayon-core-0.3
+ (package
+ (name "rust-rustc-rayon-core")
+ (version "0.3.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "rustc-rayon-core" version))
+ (file-name
+ (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1cwc50mcclzfmhmi87953fjk6cc9ppmchn9mlwzfllq03y1jf97a"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:tests? #f
+ #:cargo-inputs
+ (("rust-crossbeam-deque" ,rust-crossbeam-deque-0.7)
+ ("rust-crossbeam-queue" ,rust-crossbeam-queue-0.1)
+ ("rust-crossbeam-utils" ,rust-crossbeam-utils-0.6)
+ ("rust-lazy-static" ,rust-lazy-static-1)
+ ("rust-num-cpus" ,rust-num-cpus-1))
+ #:cargo-development-inputs
+ (("rust-libc" ,rust-libc-0.2)
+ ("rust-rand" ,rust-rand-0.6)
+ ("rust-rand-xorshift" ,rust-rand-xorshift-0.1)
+ ("rust-scoped-tls" ,rust-scoped-tls-1.0))))
+ (home-page "https://github.com/rust-lang/rustc-rayon")
+ (synopsis "Core APIs for Rayon - fork for rustc")
+ (description
+ "Note: This package is an unstable fork made for use in rustc
+
+Rayon-core represents the \"core, stable\" APIs of Rayon: join, scope, and so
+forth, as well as the ability to create custom thread-pools with ThreadPool.")
+ (license (list license:asl2.0 license:expat))))
+
(define-public rust-rustc-serialize-0.3
(package
(name "rust-rustc-serialize")