summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn Soo <jsoo1@asu.edu>2020-06-16 20:29:23 -0700
committerEfraim Flashner <efraim@flashner.co.il>2020-07-09 17:00:21 +0300
commit39662c9ddcb5770d578d64721da798297b5934a0 (patch)
tree999294cf57009acca6288da07c758d78f4fca43a
parent0d1f8b48f6764a6012fda9f29c566e99638d5835 (diff)
downloadguix-patches-39662c9ddcb5770d578d64721da798297b5934a0.tar
guix-patches-39662c9ddcb5770d578d64721da798297b5934a0.tar.gz
gnu: Add rust-rustc-ap-graphviz-654.
* gnu/packages/crates-io.scm (rust-rustc-ap-graphviz-654): New variable. Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
-rw-r--r--gnu/packages/crates-io.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 7e55d6032d..aea5ebed9a 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -20230,6 +20230,29 @@ It is automatically published using the compiler repository at
@url{https://www.github.com/rust-lang/rust}")
(license (list license:expat license:asl2.0))))
+(define-public rust-rustc-ap-graphviz-654
+ (package
+ (name "rust-rustc-ap-graphviz")
+ (version "654.0.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "rustc-ap-graphviz" version))
+ (file-name
+ (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1z8rs3k9zcd1i2clrnzgvfaq1q05m02wjcyy3d9zk9qln03vp43l"))))
+ (build-system cargo-build-system)
+ (home-page "https://github.com/alexcrichton/rustc-auto-publish")
+ (synopsis
+ "Automatically published versions of the graphviz crate used in rustc")
+ (description
+ "Use the graphviz library used in the Rust compiler with this crate.
+It is automatically published using the compiler repository at
+@url{https://www.github.com/rust-lang/rust}")
+ (license (list license:expat license:asl2.0))))
+
(define-public rust-rustc-ap-rustc-lexer-654
(package
(name "rust-rustc-ap-rustc-lexer")