summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMădălin Ionel Patrașcu <madalinionel.patrascu@mdc-berlin.de>2022-04-27 12:56:14 +0200
committerRicardo Wurmus <rekado@elephly.net>2022-04-27 16:18:27 +0200
commitbe2ead307371ae03d0b56652fc40bec11869b8a1 (patch)
treecd6e8fee558cbabdcab03304bc2951993659ab82
parent851770312fc3aed467494112174205388c49afc2 (diff)
downloadguix-patches-be2ead307371ae03d0b56652fc40bec11869b8a1.tar
guix-patches-be2ead307371ae03d0b56652fc40bec11869b8a1.tar.gz
gnu: Add r-affyrnadegradation.
* gnu/packages/bioconductor.scm (r-affyrnadegradation): New variable. Signed-off-by: Ricardo Wurmus <rekado@elephly.net>
-rw-r--r--gnu/packages/bioconductor.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index bbbe649320..088d50f7f5 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -1769,6 +1769,31 @@ impute GReX can be trained with a training dataset where the real total
expression values are known.")
(license license:gpl3)))
+(define-public r-affyrnadegradation
+ (package
+ (name "r-affyrnadegradation")
+ (version "1.40.0")
+ (source (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "AffyRNADegradation" version))
+ (sha256
+ (base32
+ "00hzr62xn1i1w4g8krsxhivzwn8hd7hwhkdxyrpz6cs9vgr4x9kd"))))
+ (properties `((upstream-name . "AffyRNADegradation")))
+ (build-system r-build-system)
+ (propagated-inputs (list r-affy))
+ (home-page "https://bioconductor.org/packages/AffyRNADegradation")
+ (synopsis
+ "Analyze and correct probe positional bias in data due to RNA degradation")
+ (description
+ "The @code{AffyRNADegradation} package helps with the assessment and
+correction of RNA degradation effects in Affymetrix 3 expression arrays. The
+parameter @code{d} gives a robust and accurate measure of RNA integrity. The
+correction removes the probe positional bias, and thus improves comparability
+of samples that are affected by RNA degradation.")
+ ;; the R file header specifies GPL2 or later
+ (license license:gpl2+)))
+
(define-public r-aneufinder
(package
(name "r-aneufinder")