summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMădălin Ionel Patrașcu <madalinionel.patrascu@mdc-berlin.de>2022-04-26 17:24:55 +0200
committerRicardo Wurmus <rekado@elephly.net>2022-04-27 16:07:58 +0200
commit851770312fc3aed467494112174205388c49afc2 (patch)
tree349fc0aa8aa331cda673fd54c39b6a61403740cd
parent43dc50a5c7271cbdea15b0e14ce69668191cfdaa (diff)
downloadguix-patches-851770312fc3aed467494112174205388c49afc2.tar
guix-patches-851770312fc3aed467494112174205388c49afc2.tar.gz
gnu: Add r-affixcan.
* gnu/packages/bioconductor.scm (r-affixcan): New variable. Signed-off-by: Ricardo Wurmus <rekado@elephly.net>
-rw-r--r--gnu/packages/bioconductor.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index 6b718b7e10..bbbe649320 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -1741,6 +1741,34 @@ annotated to, splits into two subclasses are computed and a significance of
the supporting gene set is determined.")
(license license:gpl2+)))
+(define-public r-affixcan
+ (package
+ (name "r-affixcan")
+ (version "1.12.0")
+ (source (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "AffiXcan" version))
+ (sha256
+ (base32
+ "06yn87briv2141jqad934gg5rcd90w5nghrgmbhqnmwafn72gj9d"))))
+ (properties `((upstream-name . "AffiXcan")))
+ (build-system r-build-system)
+ (propagated-inputs
+ (list r-biocparallel
+ r-crayon
+ r-multiassayexperiment
+ r-summarizedexperiment))
+ (native-inputs (list r-knitr))
+ (home-page "https://bioconductor.org/packages/AffiXcan")
+ (synopsis "Functional approach to impute genetically regulated expression")
+ (description
+ "The @code{AffiXcan} package imputes a @dfn{genetically regulated
+expression} (GReX) for a set of genes in a sample of individuals, using a
+method based on the @dfn{total binding affinity} (TBA). Statistical models to
+impute GReX can be trained with a training dataset where the real total
+expression values are known.")
+ (license license:gpl3)))
+
(define-public r-aneufinder
(package
(name "r-aneufinder")