summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Allan Webber <cwebber@dustycloud.org>2015-07-10 16:28:01 -0500
committerDavid Thompson <davet@gnu.org>2015-07-26 14:29:08 -0400
commitb8050e7183e423a3d167bfe9c7f6f373318d7878 (patch)
treed74b9da61bc7ab9379b0604bbedb915da50b6bdb
parent59ad30e3a83cb7170b0b7a0c191315f1e6c7db25 (diff)
downloadguix-patches-b8050e7183e423a3d167bfe9c7f6f373318d7878.tar
guix-patches-b8050e7183e423a3d167bfe9c7f6f373318d7878.tar.gz
gnu: Add pelican.
* gnu/packages/python.scm (pelican): New variable.
-rw-r--r--gnu/packages/python.scm51
1 files changed, 50 insertions, 1 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index eec2c11b6f..9d83e9a3af 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -28,7 +28,7 @@
(define-module (gnu packages python)
#:use-module ((guix licenses)
#:select (asl2.0 bsd-4 bsd-3 bsd-2 non-copyleft cc0 x11 x11-style
- gpl2 gpl2+ gpl3+ lgpl2.0+ lgpl2.1 lgpl2.1+ lgpl3+
+ gpl2 gpl2+ gpl3+ lgpl2.0+ lgpl2.1 lgpl2.1+ lgpl3+ agpl3+
psfl public-domain x11-style))
#:use-module ((guix licenses) #:select (expat zlib) #:prefix license:)
#:use-module (gnu packages)
@@ -2183,6 +2183,55 @@ interested parties to subscribe to events, or \"signals\".")
(define-public python2-blinker
(package-with-python2 python-blinker))
+(define-public pelican
+ (package
+ (name "pelican")
+ (version "3.6.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://pypi.python.org/packages/source/p/pelican/pelican-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "0lbkk902mqxpp452pp76n6qcjv6f99lq2zl204xmqyzcan9zr3ps"))))
+ (build-system python-build-system)
+ (native-inputs
+ `(("python-setuptools" ,python-setuptools)))
+ (propagated-inputs
+ `(("python-feedgenerator" ,python-feedgenerator)
+ ("python-jinja2" ,python-jinja2)
+ ("python-pygments" ,python-pygments)
+ ("python-docutils" ,python-docutils)
+ ("python-pytz" ,python-pytz)
+ ("python-blinker" ,python-blinker)
+ ("python-unidecode" ,python-unidecode)
+ ("python-six" ,python-six)
+ ("python-dateutil-2" ,python-dateutil-2)))
+ (home-page "http://getpelican.com/")
+ (arguments
+ `(;; XXX Requires a lot more packages to do unit tests :P
+ #:tests? #f
+ #:phases (modify-phases %standard-phases
+ (add-before
+ 'install 'adjust-requires
+ ;; Since feedgenerator is installed from git, it doesn't
+ ;; conform to the version requirements.
+ ;;
+ ;; We *do have* "feedgenerator >= 1.6", but strip off the
+ ;; version requirement so setuptools doesn't get confused.
+ (lambda _
+ (substitute* "setup.py"
+ (("['\"]feedgenerator.*?['\"]")
+ "'feedgenerator'")))))))
+ (synopsis "Python-based static site publishing system")
+ (description
+ "Pelican is a tool to generate a static blog from reStructuredText,
+Markdown input files, and more. Pelican uses Jinja2 for templating
+and is very extensible.")
+ (license agpl3+)))
+
(define-public python-scikit-learn
(package
(name "python-scikit-learn")