summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Allan Webber <cwebber@dustycloud.org>2015-07-10 16:12:47 -0500
committerDavid Thompson <davet@gnu.org>2015-07-26 13:13:36 -0400
commit59ad30e3a83cb7170b0b7a0c191315f1e6c7db25 (patch)
tree414dbcde1a53429628805d78ca88079d195277bf
parente727ed6aeffd57f0256b000af4b687d97bcb8d41 (diff)
downloadguix-patches-59ad30e3a83cb7170b0b7a0c191315f1e6c7db25.tar
guix-patches-59ad30e3a83cb7170b0b7a0c191315f1e6c7db25.tar.gz
gnu: Add python-blinker.
* gnu/packages/python.scm (python-blinker, python2-blinker): New variables.
-rw-r--r--gnu/packages/python.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 7709fbdc71..eec2c11b6f 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -2154,6 +2154,35 @@ which can produce feeds in RSS 2.0, RSS 0.91, and Atom formats.")
(define-public python2-feedgenerator
(package-with-python2 python-feedgenerator))
+(define-public python-blinker
+ (package
+ (name "python-blinker")
+ (version "1.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://pypi.python.org/packages/source/b/blinker/blinker-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "0bvfxkmjx6bpa302pv7v2vw5rwr3dlzjzfdp3bj628i6144024b8"))))
+ (build-system python-build-system)
+ (native-inputs
+ `(("python-setuptools" ,python-setuptools)))
+ ;; No "test" command supplied to setuptools, so unless there's another way
+ ;; to run tests, we're skipping them!
+ (arguments '(#:tests? #f))
+ (home-page "http://pythonhosted.org/blinker/")
+ (synopsis "Fast, simple object-to-object and broadcast signaling")
+ (description
+ "Blinker provides a fast dispatching system that allows any number of
+interested parties to subscribe to events, or \"signals\".")
+ (license license:expat)))
+
+(define-public python2-blinker
+ (package-with-python2 python-blinker))
+
(define-public python-scikit-learn
(package
(name "python-scikit-learn")