summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-12-15 14:25:30 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-12-15 15:38:52 +0100
commitb700b9ec21d5fb7664860a777c51f07015af5339 (patch)
treebc8c89f6eb3145171f59100b9f7aadcb863cb050
parent82c1111745828a9595f129360198229f1a108263 (diff)
downloadguix-patches-b700b9ec21d5fb7664860a777c51f07015af5339.tar
guix-patches-b700b9ec21d5fb7664860a777c51f07015af5339.tar.gz
gnu: Add r-flowstats.
* gnu/packages/bioconductor.scm (r-flowstats): New variable.
-rw-r--r--gnu/packages/bioconductor.scm36
1 files changed, 36 insertions, 0 deletions
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index babb553640..d5eca996ac 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -5549,6 +5549,42 @@ samples, compensation, and transformation are performed so that the output
matches the flowJo analysis.")
(license license:artistic2.0)))
+(define-public r-flowstats
+ (package
+ (name "r-flowstats")
+ (version "3.44.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "flowStats" version))
+ (sha256
+ (base32
+ "0pql0lpf90nra7w6z6nd8l9cgjlsg2pxysfravnbzfhl3pjvd96w"))))
+ (properties `((upstream-name . "flowStats")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-biobase" ,r-biobase)
+ ("r-biocgenerics" ,r-biocgenerics)
+ ("r-cluster" ,r-cluster)
+ ("r-fda" ,r-fda)
+ ("r-flowcore" ,r-flowcore)
+ ("r-flowviz" ,r-flowviz)
+ ("r-flowworkspace" ,r-flowworkspace)
+ ("r-kernsmooth" ,r-kernsmooth)
+ ("r-ks" ,r-ks)
+ ("r-lattice" ,r-lattice)
+ ("r-mass" ,r-mass)
+ ("r-ncdfflow" ,r-ncdfflow)
+ ("r-rcolorbrewer" ,r-rcolorbrewer)
+ ("r-rrcov" ,r-rrcov)))
+ (home-page "http://www.github.com/RGLab/flowStats")
+ (synopsis "Statistical methods for the analysis of flow cytometry data")
+ (description
+ "This package provides methods and functionality to analyze flow data
+that is beyond the basic infrastructure provided by the @code{flowCore}
+package.")
+ (license license:artistic2.0)))
+
(define-public r-flowsom
(package
(name "r-flowsom")