summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTanguy Le Carrour <tanguy@bioneland.org>2020-07-27 10:00:44 +0200
committerMarius Bakke <marius@gnu.org>2020-07-30 00:57:27 +0200
commit97554fb9ab181b50342df2b5a4f590f18510302f (patch)
tree1d723e6f23cb803f2c0395149fae35f67de19bbc
parentf755bb0189e0f226c4422347decbf2487a8c3a08 (diff)
downloadguix-patches-97554fb9ab181b50342df2b5a4f590f18510302f.tar
guix-patches-97554fb9ab181b50342df2b5a4f590f18510302f.tar.gz
gnu: Add python-typing-inspect.
* gnu/packages/python-xyz.scm (python-typing-inspect): New variable. Signed-off-by: Marius Bakke <marius@gnu.org>
-rw-r--r--gnu/packages/python-xyz.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 2613ca46b7..4f78f69c8e 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -12341,6 +12341,27 @@ in Python. It allows you to declare the libraries your project depends on and
it will manage (install/update) them for you.")
(license license:expat)))
+(define-public python-typing-inspect
+ (package
+ (name "python-typing-inspect")
+ (version "0.6.0")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "typing_inspect" version))
+ (sha256
+ (base32
+ "1dzs9a1pr23dhbvmnvms2jv7l7jk26023g5ysf0zvnq8b791s6wg"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ `(("python-mypy-extensions" ,python-mypy-extensions)
+ ("python-typing-extensions" ,python-typing-extensions)))
+ (home-page "https://github.com/ilevkivskyi/typing_inspect")
+ (synopsis "API for inspection of types in the Python @code{typing} module")
+ (description
+ "The @code{typing_inspect} module defines experimental API for runtime
+inspection of types defined in the Python standard typing module.")
+ (license license:expat)))
+
(define-public python-lazy-object-proxy
(package
(name "python-lazy-object-proxy")