summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTanguy Le Carrour <tanguy@bioneland.org>2020-07-27 10:00:43 +0200
committerMarius Bakke <marius@gnu.org>2020-07-30 00:57:27 +0200
commitf755bb0189e0f226c4422347decbf2487a8c3a08 (patch)
treef59ea83b77bf9f8b754ff80f1b580429325d151a
parentd4a044239b7af83e54d5c44dab3ea3299a946d9b (diff)
downloadguix-patches-f755bb0189e0f226c4422347decbf2487a8c3a08.tar
guix-patches-f755bb0189e0f226c4422347decbf2487a8c3a08.tar.gz
gnu: Add python-mypy-extensions.
* gnu/packages/python-check.scm (python-mypy-extensions): New variable. Signed-off-by: Marius Bakke <marius@gnu.org>
-rw-r--r--gnu/packages/python-check.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/python-check.scm b/gnu/packages/python-check.scm
index cf765e8106..0279a0a39b 100644
--- a/gnu/packages/python-check.scm
+++ b/gnu/packages/python-check.scm
@@ -8,6 +8,7 @@
;;; Copyright © 2020 Marius Bakke <mbakke@fastmail.com>
;;; Copyright © 2020 Edouard Klein <edk@beaver-labs.com>
;;; Copyright © 2020 Vinicius Monego <monego@posteo.net>
+;;; Copyright © 2020 Tanguy Le Carrour <tanguy@bioneland.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -818,3 +819,23 @@ it, the declaration of a name's public export semantics are not separated from
the implementation of that name.")
(license (list license:asl2.0
license:lgpl3)))) ; only for setup_helpers.py
+
+(define-public python-mypy-extensions
+ (package
+ (name "python-mypy-extensions")
+ (version "0.4.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "mypy_extensions" version))
+ (sha256
+ (base32
+ "1a04qsk8hd1lqns8w1j7cr0vmvbhg450di5k1i16kqxkbf7q30id"))))
+ (build-system python-build-system)
+ (arguments `(#:tests? #f)); no tests
+ (home-page "https://github.com/python/mypy_extensions")
+ (synopsis "Experimental extensions for MyPy")
+ (description "The @code{python-mypy-extensions} module defines
+experimental extensions to the standard @code{typing} module that are
+supported by the MyPy typechecker.")
+ (license license:expat)))