summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTanguy Le Carrour <tanguy@bioneland.org>2022-03-11 08:54:12 +0100
committerLudovic Courtès <ludo@gnu.org>2022-03-16 15:48:53 +0100
commit797e308047a81d63f2e55b8748ce743d6421cb8f (patch)
tree24c20f6aa8ef62a7f0ee37d1ccd25f99d0c1e29c
parentd7a30c6e1db04dcff75fc856ecdfd8421120eebb (diff)
downloadguix-patches-797e308047a81d63f2e55b8748ce743d6421cb8f.tar
guix-patches-797e308047a81d63f2e55b8748ce743d6421cb8f.tar.gz
* gnu/packages/password-utils.scm (tessen): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/password-utils.scm38
1 files changed, 37 insertions, 1 deletions
diff --git a/gnu/packages/password-utils.scm b/gnu/packages/password-utils.scm
index 440bb927a6..0e5f63e1be 100644
--- a/gnu/packages/password-utils.scm
+++ b/gnu/packages/password-utils.scm
@@ -23,7 +23,7 @@
;;; Copyright © 2018 Amirouche Boubekki <amirouche@hypermove.net>
;;; Copyright © 2018, 2019, 2020 Tim Gesthuizen <tim.gesthuizen@yahoo.de>
;;; Copyright © 2019 Jens Mølgaard <jens@zete.tk>
-;;; Copyright © 2019 Tanguy Le Carrour <tanguy@bioneland.org>
+;;; Copyright © 2019,2022 Tanguy Le Carrour <tanguy@bioneland.org>
;;; Copyright © 2020 Guillaume Le Vaillant <glv@posteo.net>
;;; Copyright © 2020 Brice Waegeneire <brice@waegenei.re>
;;; Copyright © 2020 Jean-Baptiste Note <jean-baptiste.note@m4x.org>
@@ -56,6 +56,7 @@
#:use-module (guix build-system go)
#:use-module (guix build-system trivial)
#:use-module (guix download)
+ #:use-module (guix gexp)
#:use-module (guix git-download)
#:use-module (guix packages)
#:use-module (gnu packages)
@@ -736,6 +737,41 @@ using password-store through rofi interface:
@end enumerate")
(license license:gpl3)))
+(define-public tessen
+ (package
+ (name "tessen")
+ (version "2.1.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/ayushnix/tessen/")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1ddsjhzp1qy3jfhxlrzcxgp0gza234yc0sdlngwa3xdj0wr40zs0"))))
+ (build-system gnu-build-system)
+ (arguments
+ (list #:tests?
+ #f ;no tests
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'patch-wtype-path
+ (lambda* (#:key inputs #:allow-other-keys)
+ (substitute* "tessen"
+ (("wtype") (search-input-file inputs "/bin/wtype")))))
+ (delete 'configure)) ;no configure script
+ #:make-flags
+ #~(list (string-append "PREFIX="
+ #$output))))
+ (native-inputs (list scdoc))
+ (inputs (list wtype))
+ (home-page "https://github.com/ayushnix/tessen")
+ (synopsis "Frontend for password-store and gopass")
+ (description "Tessen is a bash script that can autotype and copy data
+from password-store and gopass files.")
+ (license license:gpl2+)))
+
(define-public browserpass-native
(package
(name "browserpass-native")