summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDenis 'GNUtoo' Carikli <GNUtoo@cyberdimension.org>2022-02-24 21:40:48 +0100
committerLudovic Courtès <ludo@gnu.org>2022-03-16 15:48:52 +0100
commitd7a30c6e1db04dcff75fc856ecdfd8421120eebb (patch)
tree7cb0f3f79e844a25c5d24905d8a92fc3242e0258
parentfee68a93d833b7774de6b0af9ddb9f5f696922eb (diff)
downloadguix-patches-d7a30c6e1db04dcff75fc856ecdfd8421120eebb.tar
guix-patches-d7a30c6e1db04dcff75fc856ecdfd8421120eebb.tar.gz
gnu: matterbridge: update to 1.24.0
* gnu/packages/messaging.scm (matterbridge): Update to 1.24.0. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/messaging.scm59
1 files changed, 44 insertions, 15 deletions
diff --git a/gnu/packages/messaging.scm b/gnu/packages/messaging.scm
index 9f542a00b6..f78719575a 100644
--- a/gnu/packages/messaging.scm
+++ b/gnu/packages/messaging.scm
@@ -3108,23 +3108,52 @@ designed for experienced users.")
(define-public matterbridge
(package
(name "matterbridge")
- (version "1.22.2")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/42wim/matterbridge")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "07rgdc4v043fhzsalmlhickqizk6xjlpjkzn6l5v9ryp5gmv580z"))))
- (build-system go-build-system)
+ (version "1.24.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/42wim/matterbridge")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0cd70x9685162c0imdici1ipl9lziq700wzyb5bsg610wfak3ms7"))))
+ ;; Using the go-build-system results in the same error message
+ ;; than in the bug 1551[1]. So we fix it by running go build
+ ;; manually in the git repository as-is as this is the solution
+ ;; given to that bug by the matterbridge developers.
+ ;; [1]https://github.com/42wim/matterbridge/issues/1551
+ (build-system gnu-build-system)
(arguments
- `(#:import-path "github.com/42wim/matterbridge"
- #:unpack-path "github.com/42wim/matterbridge"))
+ `(#:phases (modify-phases %standard-phases
+ (delete 'configure)
+ (replace 'build
+ (lambda* (#:key outputs #:allow-other-keys)
+ (setenv "GOCACHE"
+ (string-append (getcwd) "/go-build"))
+ (setenv "GOBIN"
+ (string-append (assoc-ref outputs "out") "/bin"))
+ (invoke "go" "build" "-v" "-x")))
+ (replace 'check
+ (lambda* (#:key outputs tests? #:allow-other-keys)
+ (when tests?
+ (setenv "GOCACHE"
+ (string-append (getcwd) "/go-build"))
+ (setenv "GOBIN"
+ (string-append (assoc-ref outputs "out")
+ "/bin"))
+ (invoke "go" "test" "-v" "-x"))))
+ (replace 'install
+ (lambda* (#:key outputs #:allow-other-keys)
+ (setenv "GOCACHE"
+ (string-append (getcwd) "/go-build"))
+ (setenv "GOBIN"
+ (string-append (assoc-ref outputs "out") "/bin"))
+ (invoke "go" "install" "-v" "-x"))))))
+ (native-inputs (list go))
(synopsis "Bridge together various messaging networks and protocols")
- (description "Relays messages between different channels from various
+ (description
+ "Relays messages between different channels from various
messaging networks and protocols. So far it supports mattermost, IRC, gitter,
xmpp, slack, discord, telegram, rocketchat, twitch, ssh-chat, zulip, whatsapp,
keybase, matrix, microsoft teams, nextcloud, mumble, vk and more with REST