summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMădălin Ionel Patrașcu <madalinionel.patrascu@mdc-berlin.de>2022-04-27 13:20:14 +0200
committerRicardo Wurmus <rekado@elephly.net>2022-04-27 16:24:55 +0200
commit73fe0dab503c3a2d2a2dac291e3d3809872acbf4 (patch)
treecb9b9015d7362ab8ae4bf8717d9310b62f33a3a1
parentbe2ead307371ae03d0b56652fc40bec11869b8a1 (diff)
downloadguix-patches-73fe0dab503c3a2d2a2dac291e3d3809872acbf4.tar
guix-patches-73fe0dab503c3a2d2a2dac291e3d3809872acbf4.tar.gz
gnu: Add r-agdex.
* gnu/packages/bioconductor.scm (r-agdex): New variable. Signed-off-by: Ricardo Wurmus <rekado@elephly.net>
-rw-r--r--gnu/packages/bioconductor.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index 088d50f7f5..3d68db6d68 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -1794,6 +1794,33 @@ of samples that are affected by RNA degradation.")
;; the R file header specifies GPL2 or later
(license license:gpl2+)))
+(define-public r-agdex
+ (package
+ (name "r-agdex")
+ (version "1.42.0")
+ (source (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "AGDEX" version))
+ (sha256
+ (base32
+ "0y0q4zdybr5hlsi7qy2hf6c2sqr2z2211wz36dz70jkqyr0ggw64"))))
+ (properties `((upstream-name . "AGDEX")))
+ (build-system r-build-system)
+ (propagated-inputs (list r-biobase r-gseabase))
+ (home-page "https://bioconductor.org/packages/AGDEX")
+ (synopsis
+ "Evaluate agreement of differential expression for cross-species genomics")
+ (description
+ "The objective of @code{AGDEX} is to evaluate whether the results of a
+pair of two-group differential expression analysis comparisons show a level of
+agreement that is greater than expected if the group labels for each two-group
+comparison are randomly assigned. The agreement is evaluated for the entire
+transcriptome and (optionally) for a collection of pre-defined gene-sets.
+Additionally, the procedure performs permutation-based differential expression
+and meta analysis at both gene and gene-set levels of the data from each
+experiment.")
+ (license license:gpl2+)))
+
(define-public r-aneufinder
(package
(name "r-aneufinder")