summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPetr Hodina <phodina@protonmail.com>2022-04-06 14:36:49 +0200
committerLudovic Courtès <ludo@gnu.org>2022-04-29 18:07:16 +0200
commit6ce8d9be438f9d16338232ebf03a4f749cc1ff4f (patch)
treea29d93df4839f3293f585e7d79ace8ee5e9d23e5
parent606ba144803df497bc71444408feb990001314f6 (diff)
downloadguix-patches-6ce8d9be438f9d16338232ebf03a4f749cc1ff4f.tar
guix-patches-6ce8d9be438f9d16338232ebf03a4f749cc1ff4f.tar.gz
gnu: Add envytools.
* gnu/packages/hardware.scm (envytools): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/hardware.scm30
1 files changed, 29 insertions, 1 deletions
diff --git a/gnu/packages/hardware.scm b/gnu/packages/hardware.scm
index 60b9a9f17b..38bc3881b9 100644
--- a/gnu/packages/hardware.scm
+++ b/gnu/packages/hardware.scm
@@ -5,7 +5,7 @@
;;; Copyright © 2021 Evgeny Pisemsky <evgeny@pisemsky.com>
;;; Copyright © 2021 Léo Le Bouter <lle-bout@zaclys.net>
;;; Copyright © 2021 Denis Carikli <GNUtoo@cyberdimension.org>
-;;; Copyright © 2021 Petr Hodina <phodina@protonmail.com>
+;;; Copyright © 2021, 2022 Petr Hodina <phodina@protonmail.com>
;;; Copyright © 2021 Raghav Gururajan <rg@raghavgururajan.name>
;;; Copyright © 2021 Vinicius Monego <monego@posteo.net>
;;; Copyright © 2021, 2022 John Kehayias <john.kehayias@protonmail.com>
@@ -34,6 +34,7 @@
#:use-module (gnu packages admin)
#:use-module (gnu packages autotools)
#:use-module (gnu packages bash)
+ #:use-module (gnu packages bison)
#:use-module (gnu packages compression)
#:use-module (gnu packages check)
#:use-module (gnu packages cpp)
@@ -82,6 +83,33 @@
;; This is a module for packages related to physical hardware that don't (yet)
;; have a more specific home like gps.scm, security-token.scm, &c.
+
+(define-public envytools
+ (let ((commit "9014a51b1436461c7b3b005bdae72bf4912f4e72")
+ (revision "1"))
+ (package
+ (name "envytools")
+ (version (git-version "0.1" revision commit))
+ (home-page "https://github.com/envytools/envytools")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url home-page)
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1lqh73yxd5jgv7b770m37zimzhyn4f3053jybkixkhvm93zka8vd"))))
+ (build-system cmake-build-system)
+ (native-inputs (list bison flex pkg-config))
+ (inputs (list libxml2 python))
+ (synopsis "Reverse-engineering tools for Nvidia's proprietary GPU drivers")
+ (description
+ "This package provides tools for exploring Nvidia's proprietary GPU
+drivers, including an assembler and a disassembler for several GPU instruction
+sets, and tools to deal with register databases.")
+ (license license:expat))))
+
(define-public hwinfo
(package
(name "hwinfo")