summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Tropin <andrew@trop.in>2022-04-25 09:40:02 +0300
committerLudovic Courtès <ludo@gnu.org>2022-04-29 18:07:16 +0200
commit606ba144803df497bc71444408feb990001314f6 (patch)
tree64325aef9110e6872dfb940075807aa922bb2933
parentccd682cb9877f61d59303da96e62b2067964d1a4 (diff)
downloadguix-patches-606ba144803df497bc71444408feb990001314f6.tar
guix-patches-606ba144803df497bc71444408feb990001314f6.tar.gz
gnu: zsh: Build and install info pages.
* gnu/packages/shells.scm (zsh)[arguments]: Add 'make-info' and 'install-info' phases. [native-inputs]: Add TEXINFO. Co-authored-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/shells.scm11
1 files changed, 8 insertions, 3 deletions
diff --git a/gnu/packages/shells.scm b/gnu/packages/shells.scm
index 3a48bc7dbf..00a0ef363d 100644
--- a/gnu/packages/shells.scm
+++ b/gnu/packages/shells.scm
@@ -19,6 +19,7 @@
;;; Copyright © 2020, 2022 Marius Bakke <marius@gnu.org>
;;; Copyright © 2021, 2022 Nicolas Goaziou <mail@nicolasgoaziou.fr>
;;; Copyright © 2021, 2022 Felix Gruber <felgru@posteo.net>
+;;; Copyright © 2022 Andrew Tropin <andrew@trop.in>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -64,6 +65,7 @@
#:use-module (gnu packages tls)
#:use-module (gnu packages version-control)
#:use-module (gnu packages xorg)
+ #:use-module (gnu packages texinfo)
#:use-module (guix build-system cargo)
#:use-module (guix build-system cmake)
#:use-module (guix build-system gnu)
@@ -521,9 +523,12 @@ history mechanism, job control and a C-like syntax.")
(substitute* "Test/A01grammar.ztst"
(("command -pv") "command -v")
(("command -p") "command ")
- (("'command' -p") "'command' "))
- #t)))))
- (native-inputs (list autoconf))
+ (("'command' -p") "'command' "))))
+ (add-after 'build 'make-info
+ (lambda _ (invoke "make" "info")))
+ (add-after 'build 'install-info
+ (lambda _ (invoke "make" "install.info"))))))
+ (native-inputs (list autoconf texinfo))
(inputs (list ncurses pcre perl))
(synopsis "Powerful shell for interactive use and scripting")
(description "The Z shell (zsh) is a Unix shell that can be used