summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Kortkamp <tobias.kortkamp@gmail.com>2022-08-26 12:14:58 +0200
committerMathieu Othacehe <othacehe@gnu.org>2022-08-30 09:14:40 +0200
commit6beadc82df204f315d06ea35f2e232bb32f8e440 (patch)
tree12238859f7d08381582f7a6cb494fa18e945ac09
parent01df491f6db552dca22c00d3bd452d5a7eacb46a (diff)
downloadguix-patches-6beadc82df204f315d06ea35f2e232bb32f8e440.tar
guix-patches-6beadc82df204f315d06ea35f2e232bb32f8e440.tar.gz
gnu: wayland-protocols: Fix cross-compilationbase-for-issue-57491
* gnu/packages/freedesktop.scm (wayland-protocols): Fix cross-compilation [native-inputs]: Add pkg-config-for-build and wayland. Signed-off-by: Mathieu Othacehe <othacehe@gnu.org>
-rw-r--r--gnu/packages/freedesktop.scm7
1 files changed, 5 insertions, 2 deletions
diff --git a/gnu/packages/freedesktop.scm b/gnu/packages/freedesktop.scm
index a902fac153..d9f48b791a 100644
--- a/gnu/packages/freedesktop.scm
+++ b/gnu/packages/freedesktop.scm
@@ -1074,8 +1074,11 @@ fullscreen) or other display servers.")
(build-system meson-build-system)
(inputs
(list wayland))
- (native-inputs
- (list pkg-config python))
+ (native-inputs (cons* pkg-config python
+ (if (%current-target-system)
+ (list pkg-config-for-build
+ wayland) ; for wayland-scanner
+ '())))
(synopsis "Wayland protocols")
(description "Wayland-Protocols contains Wayland protocols that add
functionality not available in the Wayland core protocol. Such protocols either