summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxime Devos <maximedevos@telenet.be>2022-08-28 16:47:48 +0200
committerMathieu Othacehe <othacehe@gnu.org>2022-08-30 08:58:53 +0200
commit01df491f6db552dca22c00d3bd452d5a7eacb46a (patch)
tree13383e44fe4d5aeeee13faa461d62c5271ee705a
parentf60653a0efc5fa27229bf51fa66baa60c80260a5 (diff)
downloadguix-patches-01df491f6db552dca22c00d3bd452d5a7eacb46a.tar
guix-patches-01df491f6db552dca22c00d3bd452d5a7eacb46a.tar.gz
gnu: yt-dlp: Don't ask to run tests when cross-compiling.
* gnu/packages/video.scm (yt-dlp)[arguments]{#:tests?}: When cross-compiling, set to #false. Signed-off-by: Mathieu Othacehe <othacehe@gnu.org>
-rw-r--r--gnu/packages/video.scm2
1 files changed, 1 insertions, 1 deletions
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index 556eb46df4..28eb4aada4 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -2500,7 +2500,7 @@ YouTube.com and many more sites.")
(base32 "07qz1zdndlpki0asw35zk5hdjcwpl3n1g54nxg4yb1iykbyv7rll"))))
(arguments
(substitute-keyword-arguments (package-arguments youtube-dl)
- ((#:tests? _) #t)
+ ((#:tests? _) (not (%current-target-system)))
((#:phases phases)
#~(modify-phases #$phases
;; See the comment for the corresponding phase in youtube-dl.