summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn Kehayias <john.kehayias@protonmail.com>2022-04-26 12:57:09 -0400
committerLudovic Courtès <ludo@gnu.org>2022-04-29 18:07:16 +0200
commitccd682cb9877f61d59303da96e62b2067964d1a4 (patch)
tree9a56cdcbecc7c70c1f0bcf0b508f5d69976f33b0
parent2c408520f59ce7a2638dccab7017e2fcb41292a0 (diff)
downloadguix-patches-ccd682cb9877f61d59303da96e62b2067964d1a4.tar
guix-patches-ccd682cb9877f61d59303da96e62b2067964d1a4.tar.gz
gnu: lensfun: Update to 0.3.3.
* gnu/packages/photo.scm (lensfun): Update to 0.3.3. [source, homepage]: Update URLs as the project has moved. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/photo.scm22
1 files changed, 12 insertions, 10 deletions
diff --git a/gnu/packages/photo.scm b/gnu/packages/photo.scm
index 2f561abc2f..f534a013bc 100644
--- a/gnu/packages/photo.scm
+++ b/gnu/packages/photo.scm
@@ -9,6 +9,7 @@
;;; Copyright © 2020 Sebastian Schott <sschott@mailbox.org>
;;; Copyright © 2020 Vincent Legoll <vincent.legoll@gmail.com>
;;; Copyright © 2020. 2021, 2022 Vinicius Monego <monego@posteo.net>
+;;; Copyright © 2022 John Kehayias <john.kehayias@protonmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -415,15 +416,16 @@ scene to produce an image that looks much like a tone-mapped image.")
(define-public lensfun
(package
(name "lensfun")
- (version "0.3.2")
- (source (origin
- (method url-fetch)
- (uri (string-append
- "mirror://sourceforge/lensfun/"
- version "/lensfun-" version ".tar.gz"))
- (sha256
- (base32
- "0cfk8jjhs9nbfjfdy98plrj9ayi59aph0nx6ppslgjhlcvacm2xf"))))
+ (version "0.3.3")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/lensfun/lensfun")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1pv2y9yqzkw70p501425mf9cqv6yy8ppw5ilkpbd9bw9nss1js76"))))
(build-system cmake-build-system)
(arguments
`(,@(if (any (cute string-prefix? <> (or (%current-system)
@@ -437,7 +439,7 @@ scene to produce an image that looks much like a tone-mapped image.")
(list pkg-config))
(inputs
(list glib))
- (home-page "https://sourceforge.net/projects/lensfun/")
+ (home-page "https://lensfun.github.io/")
(synopsis "Library to correct optical lens defects with a lens database")
(description "Digital photographs are not ideal. Of course, the better is
your camera, the better the results will be, but in any case if you look