summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn Soo <jsoo1@asu.edu>2020-06-16 20:47:33 -0700
committerEfraim Flashner <efraim@flashner.co.il>2020-07-09 17:00:22 +0300
commit5850a02185c8d72bdce0ba09d67f54be02686cf0 (patch)
tree2e8747859cad95bc1292395cc16a83d3d7f5c256
parentcb123dad5e36b208572ea5acfcaa93c201215e4d (diff)
downloadguix-patches-5850a02185c8d72bdce0ba09d67f54be02686cf0.tar
guix-patches-5850a02185c8d72bdce0ba09d67f54be02686cf0.tar.gz
gnu: Add rust-rustc-rayon-0.3.
* gnu/packages/crates-io.scm (rust-rustc-rayon-0.3): New variable. Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
-rw-r--r--gnu/packages/crates-io.scm39
1 files changed, 39 insertions, 0 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 1dad5d1608..efd3c09db1 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -20353,6 +20353,45 @@ It is automatically published using the compiler repository at
"This package provides a speedy, non-cryptographic hash used in rustc.")
(license (list license:asl2.0 license:expat))))
+(define-public rust-rustc-rayon-0.3
+ (package
+ (name "rust-rustc-rayon")
+ (version "0.3.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "rustc-rayon" version))
+ (file-name
+ (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0fjvy8bf0hd1zq9d3fdxbdp4z4p1k8jfyx51k5qip3wk1pwnf9zk"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:tests? #f
+ #:cargo-inputs
+ (("rust-crossbeam-deque" ,rust-crossbeam-deque-0.7)
+ ("rust-either" ,rust-either-1.5)
+ ("rust-rustc-rayon-core" ,rust-rustc-rayon-core-0.3))
+ #:cargo-development-inputs
+ (("rust-doc-comment" ,rust-doc-comment-0.3)
+ ("rust-docopt" ,rust-docopt-1.1)
+ ("rust-lazy-static" ,rust-lazy-static-1)
+ ("rust-rand" ,rust-rand-0.6)
+ ("rust-rand-xorshift" ,rust-rand-xorshift-0.1)
+ ("rust-serde" ,rust-serde-1.0)
+ ("rust-serde-derive" ,rust-serde-derive-1.0))))
+ (home-page "https://github.com/rust-lang/rustc-rayon")
+ (synopsis
+ "Simple work-stealing parallelism for Rust - fork for rustc")
+ (description
+ "Rustc-rayon is a fork of the Rayon crate. It adds a few \"in progress\"
+features that rustc is using, mostly around deadlock detection. These features
+are not stable and should not be used by others -- though they may find their
+way into rayon proper at some point. In general, if you are not rustc, you
+should be using the real rayon crate, not rustc-rayon.")
+ (license (list license:asl2.0 license:expat))))
+
(define-public rust-rustc-rayon-core-0.3
(package
(name "rust-rustc-rayon-core")