summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTanguy Le Carrour <tanguy@bioneland.org>2020-07-27 22:08:18 +0200
committerMarius Bakke <marius@gnu.org>2020-07-30 00:57:29 +0200
commit4f0f00d757181d43eb233c2110fc984247c0904b (patch)
treebe414b88462d9146417b16ce76248bf14f45644f
parent43d8faf8de1683e9ed452206313509c003a619d5 (diff)
downloadguix-patches-4f0f00d757181d43eb233c2110fc984247c0904b.tar
guix-patches-4f0f00d757181d43eb233c2110fc984247c0904b.tar.gz
gnu: python-cookiecutter: Update to 1.7.2.
* gnu/packages/python-xyz.scm (python-cookiecutter): Update to 1.7.2. [propagated-inputs]: Add python-slugify, python-text-unidecode. [home-page]: Update URL. Signed-off-by: Marius Bakke <marius@gnu.org>
-rw-r--r--gnu/packages/python-xyz.scm8
1 files changed, 5 insertions, 3 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 0050427247..0b33fb3a4c 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -10656,14 +10656,14 @@ designed to work across multiple versions of Python.")
(define-public python-cookiecutter
(package
(name "python-cookiecutter")
- (version "1.6.0")
+ (version "1.7.2")
(source
(origin
(method url-fetch)
(uri (pypi-uri "cookiecutter" version))
(sha256
(base32
- "0glsvaz8igi2wy1hsnhm9fkn6560vdvdixzvkq6dn20z3hpaa5hk"))))
+ "1b2xa5dypk1vf8aq599fd8zw4y0pwvq3hgl7ia8aiv8gg3ab5dpg"))))
(build-system python-build-system)
(native-inputs
`(("python-freezegun" ,python-freezegun)
@@ -10679,8 +10679,10 @@ designed to work across multiple versions of Python.")
("python-jinja2-time" ,python-jinja2-time)
("python-poyo" ,python-poyo)
("python-requests" ,python-requests)
+ ("python-slugify" ,python-slugify)
+ ("python-text-unidecode" ,python-text-unidecode)
("python-whichcraft" ,python-whichcraft)))
- (home-page "https://github.com/audreyr/cookiecutter")
+ (home-page "https://github.com/cookiecutter/cookiecutter")
(synopsis
"Command-line utility that creates projects from project templates")
(description