summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2015-10-06 15:18:44 +0200
committerLudovic Courtès <ludo@gnu.org>2015-10-06 15:18:44 +0200
commit42e735dfc78ff89aff8a6e6e6dc60142f4ee2bf3 (patch)
tree21ed16a42e0c176c2dca85bb5f63ea7694cace8e
parent18bf40a087bbb9d671f9fcb9ff6e26b94ba02ffa (diff)
downloadguix-patches-42e735dfc78ff89aff8a6e6e6dc60142f4ee2bf3.tar
guix-patches-42e735dfc78ff89aff8a6e6e6dc60142f4ee2bf3.tar.gz
gnu: gmp: Skip unreliable test.
* gnu/packages/patches/gmp-faulty-test.patch: New file. * gnu-system.am (dist_patch_DATA): Add it. * gnu/packages/multiprecision.scm (gmp)[source]: Use it.
-rw-r--r--gnu-system.am1
-rw-r--r--gnu/packages/multiprecision.scm6
-rw-r--r--gnu/packages/patches/gmp-faulty-test.patch11
3 files changed, 16 insertions, 2 deletions
diff --git a/gnu-system.am b/gnu-system.am
index 4db5db58ec..cdae0ed1b9 100644
--- a/gnu-system.am
+++ b/gnu-system.am
@@ -474,6 +474,7 @@ dist_patch_DATA = \
gnu/packages/patches/glibc-o-largefile.patch \
gnu/packages/patches/glibc-versioned-locpath.patch \
gnu/packages/patches/gmp-arm-asm-nothumb.patch \
+ gnu/packages/patches/gmp-faulty-test.patch \
gnu/packages/patches/gnucash-price-quotes-perl.patch \
gnu/packages/patches/gnutls-doc-fix.patch \
gnu/packages/patches/gobject-introspection-absolute-shlib-path.patch \
diff --git a/gnu/packages/multiprecision.scm b/gnu/packages/multiprecision.scm
index 903d160b24..ee74c03700 100644
--- a/gnu/packages/multiprecision.scm
+++ b/gnu/packages/multiprecision.scm
@@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2012, 2013 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2012, 2013, 2015 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2014 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2015 Andreas Enge <andreas@enge.fr>
;;;
@@ -39,7 +39,9 @@
(sha256
(base32
"0r5pp27cy7ch3dg5v0rsny8bib1zfvrza6027g2mp5f6v8pd6mli"))
- (patches (list (search-patch "gmp-arm-asm-nothumb.patch")))))
+ (patches (map search-patch
+ '("gmp-arm-asm-nothumb.patch"
+ "gmp-faulty-test.patch")))))
(build-system gnu-build-system)
(native-inputs `(("m4" ,m4)))
(outputs '("out" "debug"))
diff --git a/gnu/packages/patches/gmp-faulty-test.patch b/gnu/packages/patches/gmp-faulty-test.patch
new file mode 100644
index 0000000000..3fd8a1f8d6
--- /dev/null
+++ b/gnu/packages/patches/gmp-faulty-test.patch
@@ -0,0 +1,11 @@
+Skip a test that randomly fails on ARMv7: <http://bugs.gnu.org/21620>.
+
+--- a/tests/mpz/reuse.c
++++ b/tests/mpz/reuse.c
+@@ -213,6 +213,7 @@ main (int argc, char **argv)
+ mpz_t bs;
+ unsigned long bsi, size_range;
+
++ exit (77); /* skip */
+ tests_start ();
+ TESTS_REPS (reps, argv, argc);