summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/gmp-faulty-test.patch
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/patches/gmp-faulty-test.patch')
-rw-r--r--gnu/packages/patches/gmp-faulty-test.patch11
1 files changed, 11 insertions, 0 deletions
diff --git a/gnu/packages/patches/gmp-faulty-test.patch b/gnu/packages/patches/gmp-faulty-test.patch
new file mode 100644
index 0000000000..3fd8a1f8d6
--- /dev/null
+++ b/gnu/packages/patches/gmp-faulty-test.patch
@@ -0,0 +1,11 @@
+Skip a test that randomly fails on ARMv7: <http://bugs.gnu.org/21620>.
+
+--- a/tests/mpz/reuse.c
++++ b/tests/mpz/reuse.c
+@@ -213,6 +213,7 @@ main (int argc, char **argv)
+ mpz_t bs;
+ unsigned long bsi, size_range;
+
++ exit (77); /* skip */
+ tests_start ();
+ TESTS_REPS (reps, argv, argc);