summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMădălin Ionel Patrașcu <madalinionel.patrascu@mdc-berlin.de>2022-04-27 13:44:36 +0200
committerRicardo Wurmus <rekado@elephly.net>2022-04-27 16:29:20 +0200
commit37f584592ad7ac1ce9644b14bf96a2620be0b237 (patch)
tree40497108d517c61d1ca8a09c5425471f20f4f060
parent73fe0dab503c3a2d2a2dac291e3d3809872acbf4 (diff)
downloadguix-patches-37f584592ad7ac1ce9644b14bf96a2620be0b237.tar
guix-patches-37f584592ad7ac1ce9644b14bf96a2620be0b237.tar.gz
gnu: Add r-aggregatebiovar.
* gnu/packages/bioconductor.scm (r-aggregatebiovar): New variable. Signed-off-by: Ricardo Wurmus <rekado@elephly.net>
-rw-r--r--gnu/packages/bioconductor.scm34
1 files changed, 34 insertions, 0 deletions
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index 3d68db6d68..b760db2db7 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -1821,6 +1821,40 @@ and meta analysis at both gene and gene-set levels of the data from each
experiment.")
(license license:gpl2+)))
+(define-public r-aggregatebiovar
+ (package
+ (name "r-aggregatebiovar")
+ (version "1.4.0")
+ (source (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "aggregateBioVar" version))
+ (sha256
+ (base32
+ "1wbfp1pf62di6pzxsf36lmzk6y9dllz1n4iv3mhpb1x8cvy4hqqk"))))
+ (properties `((upstream-name . "aggregateBioVar")))
+ (build-system r-build-system)
+ (propagated-inputs
+ (list r-matrix
+ r-rlang
+ r-s4vectors
+ r-singlecellexperiment
+ r-summarizedexperiment
+ r-tibble))
+ (native-inputs (list r-knitr))
+ (home-page "https://github.com/jasonratcliff/aggregateBioVar")
+ (synopsis "Differential gene expression analysis for multi-subject scRNA-seq")
+ (description
+ "This package @code{aggregateBioVar} contains tools to summarize single
+cell gene expression profiles at the level of subject for single cell RNA-seq
+data collected from more than one subject (e.g. biological sample or technical
+replicates). A @code{SingleCellExperiment} object is taken as input and
+converted to a list of @code{SummarizedExperiment} objects, where each list
+element corresponds to an assigned cell type. The @code{SummarizedExperiment}
+objects contain aggregate gene-by-subject count matrices and inter-subject
+column metadata for individual subjects that can be processed using downstream
+bulk RNA-seq tools.")
+ (license license:gpl3)))
+
(define-public r-aneufinder
(package
(name "r-aneufinder")