summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPhilip McGrath <philip@philipmcgrath.com>2022-02-27 16:29:12 -0500
committerLiliana Marie Prikler <liliana.prikler@gmail.com>2022-03-04 23:43:32 +0100
commit37a75d23a91acab454fbbada09f4adced4487077 (patch)
tree8fce3152335f63a933c18f66a62995e1394078d1
parent2a3946bae9f8297ca9763b1f83a349edaa836d4d (diff)
downloadguix-patches-37a75d23a91acab454fbbada09f4adced4487077.tar
guix-patches-37a75d23a91acab454fbbada09f4adced4487077.tar.gz
gnu: chez-scheme: Use shared zlib and lz4.
This change also involves building 'libkernel.a' instead of 'kernel.o'. Support for these build options was merged upstream in 2019: see discussion at <https://github.com/cisco/ChezScheme/pull/443>. * gnu/packages/chez.scm (chez-scheme)[inputs]: Remove 'zlib:static' and 'lz4:static'. [arguments]: Adjust configure phase accordingly. Signed-off-by: Liliana Marie Prikler <liliana.prikler@gmail.com>
-rw-r--r--gnu/packages/chez.scm18
1 files changed, 8 insertions, 10 deletions
diff --git a/gnu/packages/chez.scm b/gnu/packages/chez.scm
index f4c87fbcf7..dd40baa719 100644
--- a/gnu/packages/chez.scm
+++ b/gnu/packages/chez.scm
@@ -211,9 +211,7 @@ If native threads are supported, the returned list will include
(inputs
`(("libuuid" ,util-linux "lib")
("zlib" ,zlib)
- ("zlib:static" ,zlib "static")
("lz4" ,lz4)
- ("lz4:static" ,lz4 "static")
;; for expeditor:
("ncurses" ,ncurses)
;; for X11 clipboard support in expeditor:
@@ -266,14 +264,14 @@ If native threads are supported, the returned list will include
(lz4-static (assoc-ref inputs "lz4:static"))
(out (assoc-ref outputs "out"))
;; add flags which are always required:
- (flags (cons*
- (string-append "--installprefix=" out)
- (string-append "ZLIB=" zlib-static "/lib/libz.a")
- (string-append "LZ4=" lz4-static "/lib/liblz4.a")
- ;; Guix will do compress man pages,
- ;; and letting Chez try causes an error
- "--nogzip-man-pages"
- configure-flags)))
+ (flags (cons* (string-append "--installprefix=" out)
+ "ZLIB=-lz"
+ "LZ4=-llz4"
+ "--libkernel"
+ ;; Guix will do compress-man-pages,
+ ;; and letting Chez try causes an error
+ "--nogzip-man-pages"
+ configure-flags)))
(format #t "configure flags: ~s~%" flags)
;; Some makefiles (for tests) don't seem to propagate CC
;; properly, so we take it out of their hands: