summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPhilip McGrath <philip@philipmcgrath.com>2022-02-27 16:29:11 -0500
committerLiliana Marie Prikler <liliana.prikler@gmail.com>2022-03-04 23:43:25 +0100
commit2a3946bae9f8297ca9763b1f83a349edaa836d4d (patch)
treeab36dba0bfeca181bc16484823ad7f4580a99fb3
parent346d8b9a49e3b9e29526356ce5694eaa27d034fc (diff)
downloadguix-patches-2a3946bae9f8297ca9763b1f83a349edaa836d4d.tar
guix-patches-2a3946bae9f8297ca9763b1f83a349edaa836d4d.tar.gz
gnu: chez-scheme: Use "lib/chez-scheme" for search path.
There does not seem to be any widely accepted standard path to use for "CHEZSCHEMELIBDIRS". Using a path without a version number in it avoids having to compute the actual path everywhere, which would be especially unpleasant when support is added for the Racket variant of Chez Scheme, which always has a different version number than upstream. * gnu/packages/chez.scm (chez-scheme)[native-search-paths]: Change to use "lib/chez-scheme" instead of "lib/csvX.Y.Z-site" for "CHEZSCHEMELIBDIRS". (chez-make-flags): Update accordingly. (chez-sockets)[arguments]<#:phases>: Likewise. Signed-off-by: Liliana Marie Prikler <liliana.prikler@gmail.com>
-rw-r--r--gnu/packages/chez.scm16
1 files changed, 6 insertions, 10 deletions
diff --git a/gnu/packages/chez.scm b/gnu/packages/chez.scm
index 4ee9711bb4..f4c87fbcf7 100644
--- a/gnu/packages/chez.scm
+++ b/gnu/packages/chez.scm
@@ -233,7 +233,7 @@ If native threads are supported, the returned list will include
(native-search-paths
(list (search-path-specification
(variable "CHEZSCHEMELIBDIRS")
- (files (list (string-append "lib/csv" version "-site"))))))
+ (files '("lib/chez-scheme")))))
(outputs '("out" "doc"))
(arguments
`(#:modules
@@ -458,9 +458,9 @@ Chez Scheme.")
(define (chez-make-flags name version)
#~(let ((out #$output))
(list
- ;; Set 'chezversion' so that libraries are installed in
- ;; 'lib/csvX.Y.Z-site' like Chez's 'native-search-paths' expects.
- (string-append "chezversion=" #$(package-version chez-scheme))
+ ;; Set 'schemedir' so that libraries are installed in
+ ;; 'lib/chez-scheme' like Chez's 'native-search-paths' expects.
+ (string-append "schemedir=" out "/lib/chez-scheme")
(string-append "PREFIX=" out)
(string-append "DOCDIR=" out "/share/doc/" #$name "-" #$version))))
@@ -608,9 +608,7 @@ programming in Scheme.")
(replace 'build
(lambda args
(let ((chez-site (string-append #$output
- "/lib/csv"
- (package-version chez-scheme)
- "-site/arcfide")))
+ "/lib/chez-scheme/arcfide")))
;; make sure Chez Scheme can find the shared libraries.
(substitute* "sockets.ss"
(("(object \")(socket-ffi-values\\.[sd][oy][^\"]*)(\")"
@@ -634,9 +632,7 @@ programming in Scheme.")
(lambda args
(install-file "sockets.so"
(string-append #$output
- "/lib/csv"
- #$(package-version chez-scheme)
- "-site/arcfide"))
+ "/lib/chez-scheme/arcfide"))
(install-file "sockets.pdf"
(string-append #$output
"/share/doc/"