summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2021-07-02 20:31:48 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2021-07-02 20:31:54 +0200
commit159de0362b97fd8003664ed0683533aae7725dcb (patch)
treeb20b88666f810f8d59711f441cd37225c4b3ba9e
parent83da1cb65a3470a7240574320fff7d35f8a50300 (diff)
downloadguix-patches-159de0362b97fd8003664ed0683533aae7725dcb.tar
guix-patches-159de0362b97fd8003664ed0683533aae7725dcb.tar.gz
gnu: shellcheck: Hide irrelevant CVE from ‘guix lint’.
* gnu/packages/haskell-apps.scm (shellcheck)[properties]: Add CVE-2021-28794 to lint-hidden-cve.
-rw-r--r--gnu/packages/haskell-apps.scm2
1 files changed, 2 insertions, 0 deletions
diff --git a/gnu/packages/haskell-apps.scm b/gnu/packages/haskell-apps.scm
index 5260326311..d06a0a330f 100644
--- a/gnu/packages/haskell-apps.scm
+++ b/gnu/packages/haskell-apps.scm
@@ -890,6 +890,8 @@ that cause a shell to behave strangely and counter-intuitively.
@item Point out subtle caveats, corner cases and pitfalls that may cause an
advanced user's otherwise working script to fail under future circumstances.
@end enumerate")
+ ;; CVE-2021-28794 is for a completely different, unofficial add-on.
+ (properties `((lint-hidden-cve . ("CVE-2021-28794"))))
(license license:gpl3+)))
(define-public shelltestrunner