summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMorgan Smith <Morgan.J.Smith@outlook.com>2021-07-02 14:10:02 -0400
committerTobias Geerinckx-Rice <me@tobias.gr>2021-07-02 20:31:12 +0200
commit83da1cb65a3470a7240574320fff7d35f8a50300 (patch)
tree0219e3ed8a10b5ba71cfb55107bf2bdde0479eea
parent70af5bf17f0654c8aa07e7aebeb5253208ebd0ca (diff)
downloadguix-patches-83da1cb65a3470a7240574320fff7d35f8a50300.tar
guix-patches-83da1cb65a3470a7240574320fff7d35f8a50300.tar.gz
gnu: shellcheck: Generate and install man page.
* gnu/packages/haskell-apps.scm (shellcheck) [arguments]<#:phases>: Add build-man-page and install-man-page phases. [native-inputs]: Add pandoc. Signed-off-by: Tobias Geerinckx-Rice <me@tobias.gr>
-rw-r--r--gnu/packages/haskell-apps.scm14
1 files changed, 14 insertions, 0 deletions
diff --git a/gnu/packages/haskell-apps.scm b/gnu/packages/haskell-apps.scm
index ebf7f5ef82..5260326311 100644
--- a/gnu/packages/haskell-apps.scm
+++ b/gnu/packages/haskell-apps.scm
@@ -17,6 +17,7 @@
;;; Copyright © 2020 Brian Leung <bkleung89@gmail.com>
;;; Copyright © 2021 EuAndreh <eu@euandre.org>
;;; Copyright © 2021 Stefan Reichör <stefan@xsteve.at>
+;;; Copyright © 2021 Morgan Smith <Morgan.J.Smith@outlook.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -857,6 +858,19 @@ too slow and you'll get wound up in the scroll and crushed.")
(base32 "06m4wh891nah3y0br4wh3adpsb16zawkb2ijgf1vcz61fznj6ps1"))
(file-name (string-append name "-" version ".tar.gz"))))
(build-system haskell-build-system)
+ (arguments
+ '(#:phases
+ (modify-phases %standard-phases
+ (add-after 'build 'build-man-page
+ (lambda _
+ (invoke "./manpage")))
+ (add-after 'install 'install-man-page
+ (lambda* (#:key outputs #:allow-other-keys)
+ (install-file "shellcheck.1"
+ (string-append (assoc-ref outputs "out")
+ "/share/man/man1/")))))))
+ (native-inputs
+ `(("pandoc" ,pandoc)))
(inputs
`(("ghc-aeson" ,ghc-aeson)
("ghc-diff" ,ghc-diff)