summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2020-06-27 00:45:26 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2020-06-27 00:45:26 -0400
commit1157d2f82c62a60cc180bd727aebc98a2f4a9f09 (patch)
tree4de45b80c078b6276ed87dfad34691c4aa9fe487
parentaa3c76b100d2916b90fb16f9c46e6ea16e9e5d20 (diff)
downloadguix-patches-1157d2f82c62a60cc180bd727aebc98a2f4a9f09.tar
guix-patches-1157d2f82c62a60cc180bd727aebc98a2f4a9f09.tar.gz
gnu: Add ruby-chandler.
* gnu/packages/ruby.scm (ruby-chandler): New variable.
-rw-r--r--gnu/packages/ruby.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 17c6fd13ce..2537a26a96 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -6161,6 +6161,30 @@ follows Ruby conventions and requires little knowledge of REST.")
(home-page "https://github.com/octokit/octokit.rb")
(license license:expat)))
+(define-public ruby-chandler
+ (package
+ (name "ruby-chandler")
+ (version "0.9.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (rubygems-uri "chandler" version))
+ (sha256
+ (base32
+ "1n8a4mr2jkcz5vaaps45g2rxa2pzy1wb7cylgw85xmmyyp14lnrr"))))
+ (build-system ruby-build-system)
+ (native-inputs
+ `(("ruby-rubocop" ,ruby-rubocop)))
+ (propagated-inputs
+ `(("ruby-netrc" ,ruby-netrc)
+ ("ruby-octokit" ,ruby-octokit)))
+ (synopsis "Sync CHANGELOG entries to GitHub's release notes")
+ (description "Chandler syncs a project's CHANGELOG file entries to
+GitHub's release notes to remove the need of manually entering release
+notes.")
+ (home-page "https://github.com/mattbrictson/chandler")
+ (license license:expat)))
+
(define-public ruby-gherkin
(package
(name "ruby-gherkin")