summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2020-06-27 00:37:22 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2020-06-27 00:37:22 -0400
commitaa3c76b100d2916b90fb16f9c46e6ea16e9e5d20 (patch)
tree934b824fcf1f69b21ebdb877421bf1431dfb0f87
parent03a0f98a8d41627bbaa7b61d4d36bd9936c2e215 (diff)
downloadguix-patches-aa3c76b100d2916b90fb16f9c46e6ea16e9e5d20.tar
guix-patches-aa3c76b100d2916b90fb16f9c46e6ea16e9e5d20.tar.gz
gnu: Add ruby-octokit.
* gnu/packages/ruby.scm (ruby-octokit): New variable.
-rw-r--r--gnu/packages/ruby.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 9db9353636..17c6fd13ce 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -6139,6 +6139,28 @@ top of Faraday.")
(home-page "https://github.com/lostisland/sawyer")
(license license:expat)))
+(define-public ruby-octokit
+ (package
+ (name "ruby-octokit")
+ (version "4.18.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (rubygems-uri "octokit" version))
+ (sha256
+ (base32
+ "0zvfr9njmj5svi39fcsi2b0g7pcxb0vamw9dlyas8bg814jlzhi6"))))
+ (build-system ruby-build-system)
+ (arguments '(#:tests? #f)) ;no test suite in the gem release
+ (propagated-inputs
+ `(("ruby-faraday" ,ruby-faraday)
+ ("ruby-sawyer" ,ruby-sawyer)))
+ (synopsis "Ruby toolkit for the GitHub API")
+ (description "Octokit wraps the GitHub API in a flat API client that
+follows Ruby conventions and requires little knowledge of REST.")
+ (home-page "https://github.com/octokit/octokit.rb")
+ (license license:expat)))
+
(define-public ruby-gherkin
(package
(name "ruby-gherkin")