summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTanguy Le Carrour <tanguy@bioneland.org>2020-07-27 10:00:45 +0200
committerMarius Bakke <marius@gnu.org>2020-07-30 00:57:27 +0200
commit100f7f9d028f80ab4feb50b3faf63e66cf12369d (patch)
tree4a62f2f2afa5f16bbc2367ed56b18a23bd8980ac
parent97554fb9ab181b50342df2b5a4f590f18510302f (diff)
downloadguix-patches-100f7f9d028f80ab4feb50b3faf63e66cf12369d.tar
guix-patches-100f7f9d028f80ab4feb50b3faf63e66cf12369d.tar.gz
gnu: Add python-hypothesis-5.23.
* gnu/packages/check.scm (python-hypothesis-5.23): New variable. Signed-off-by: Marius Bakke <marius@gnu.org>
-rw-r--r--gnu/packages/check.scm13
1 files changed, 13 insertions, 0 deletions
diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index 661ed65e53..ab1839e0a2 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -34,6 +34,7 @@
;;; Copyright © 2020 Brice Waegeneire <brice@waegenei.re>
;;; Copyright © 2020 Josh Marshall <joshua.r.marshall.1991@gmail.com>
;;; Copyright © 2020 Vinicius Monego <monego@posteo.net>
+;;; Copyright © 2020 Tanguy Le Carrour <tanguy@bioneland.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1824,6 +1825,18 @@ seamlessly into your existing Python unit testing work flow.")
(license license:mpl2.0)
(properties `((python2-variant . ,(delay python2-hypothesis))))))
+(define-public python-hypothesis-5.23
+ (package
+ (inherit python-hypothesis)
+ (version "5.23.0")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "hypothesis" version))
+ (sha256
+ (base32
+ "0sy1v6nyxg4rjcf3rlr8nalb7wqd9nccpb2lzkchbj5an13ysf1h"))))
+ (home-page "https://github.com/HypothesisWorks/hypothesis")))
+
;; This is the last version of Hypothesis that supports Python 2.
(define-public python2-hypothesis
(let ((hypothesis (package-with-python2