summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/emacs-xyz.scm7
1 files changed, 7 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 146e1aedb1..4195fe2e7a 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -4724,6 +4724,13 @@ keep pressing the key until it selects what you want. There's also
(list emacs-buttercup))
(arguments
'(#:tests? #t
+ #:phases
+ (modify-phases %standard-phases
+ ;; This causes the byte-compilation before unit-tests to fail.
+ (add-after 'unpack 'remove-error-on-warn
+ (lambda _
+ (substitute* "Makefile"
+ (("--eval '\\(setq byte-compile-error-on-warn t\\)'") "")))))
;; Don't run case-tests as they will fail to create sockets because
;; the path is too long
#:test-command '("make" "byte-compile" "unit-tests")