summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorluishgh <51053603+luishgh@users.noreply.github.com>2022-05-16 22:48:45 -0300
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2022-05-17 09:12:42 +0200
commit573531e57ed51244e0208a2dd9cdb0457c7692c4 (patch)
tree4b5ecae396ff589480b8f3f8ad5e54cf1d4775ac
parent9726745eb0219c24638ef12da83c2c6f9e7bcc00 (diff)
downloadguix-patches-573531e57ed51244e0208a2dd9cdb0457c7692c4.tar
guix-patches-573531e57ed51244e0208a2dd9cdb0457c7692c4.tar.gz
gnu: emacs-explain-pause-mode: Fix build.
* gnu/packages/emacs-xyz.scm (emacs-explain-pause-mode)[arguments]<#:phases>: Fix failing tests. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
-rw-r--r--gnu/packages/emacs-xyz.scm7
1 files changed, 7 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 146e1aedb1..4195fe2e7a 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -4724,6 +4724,13 @@ keep pressing the key until it selects what you want. There's also
(list emacs-buttercup))
(arguments
'(#:tests? #t
+ #:phases
+ (modify-phases %standard-phases
+ ;; This causes the byte-compilation before unit-tests to fail.
+ (add-after 'unpack 'remove-error-on-warn
+ (lambda _
+ (substitute* "Makefile"
+ (("--eval '\\(setq byte-compile-error-on-warn t\\)'") "")))))
;; Don't run case-tests as they will fail to create sockets because
;; the path is too long
#:test-command '("make" "byte-compile" "unit-tests")