summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxime Devos <maximedevos@telenet.be>2022-05-07 08:37:35 +0000
committerLudovic Courtès <ludo@gnu.org>2022-05-13 17:16:08 +0200
commiteebcfc65d89419d046f6f0789cf3c79676cecec5 (patch)
tree829cfe99e7a51bb8b711b7d5c3ce6a9303861541
parent579270c6bf1ec5662efc1e166f3a430b59edf3c9 (diff)
downloadguix-patches-eebcfc65d89419d046f6f0789cf3c79676cecec5.tar
guix-patches-eebcfc65d89419d046f6f0789cf3c79676cecec5.tar.gz
gnu: curl: Use $SSL_CERT_DIR/$SSL_CERT_FILE.
* gnu/packages/curl.scm (curl)[native-search-paths]: Use the $SSL_CERT_DIR/$SSL_CERT_FILE from (guix search-paths) instead of a local copy. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/curl.scm12
1 files changed, 3 insertions, 9 deletions
diff --git a/gnu/packages/curl.scm b/gnu/packages/curl.scm
index a83ecbaa09..7fa0261147 100644
--- a/gnu/packages/curl.scm
+++ b/gnu/packages/curl.scm
@@ -41,6 +41,7 @@
#:use-module (guix build-system gnu)
#:use-module (guix build-system go)
#:use-module (guix build-system meson)
+ #:use-module ((guix search-paths) #:select ($SSL_CERT_DIR $SSL_CERT_FILE))
#:use-module (gnu packages)
#:use-module (gnu packages check)
#:use-module (gnu packages compression)
@@ -82,15 +83,8 @@
("python" ,python-minimal-wrapper)))
(native-search-paths
;; These variables are introduced by curl-use-ssl-cert-env.patch.
- (list (search-path-specification
- (variable "SSL_CERT_DIR")
- (separator #f) ;single entry
- (files '("etc/ssl/certs")))
- (search-path-specification
- (variable "SSL_CERT_FILE")
- (file-type 'regular)
- (separator #f) ;single entry
- (files '("etc/ssl/certs/ca-certificates.crt")))
+ (list $SSL_CERT_DIR
+ $SSL_CERT_FILE
;; Note: This search path is respected by the `curl` command-line
;; tool only. Patching libcurl to read it too would bring no
;; advantages and require maintaining a more complex patch.