summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxime Devos <maximedevos@telenet.be>2022-05-07 08:37:34 +0000
committerLudovic Courtès <ludo@gnu.org>2022-05-13 17:16:04 +0200
commit579270c6bf1ec5662efc1e166f3a430b59edf3c9 (patch)
treea3255e8faa75e1bd172a405a1ace7a97d0f166fe
parent39420f27eee3a0aa18f8129b7db956a9196bf048 (diff)
downloadguix-patches-579270c6bf1ec5662efc1e166f3a430b59edf3c9.tar
guix-patches-579270c6bf1ec5662efc1e166f3a430b59edf3c9.tar.gz
gnu: cmake-bootstrap: Use $SSL_CERT_DIR/$SSL_CERT_FILE.
* gnu/packages/cmake.scm (cmake-bootstrap)[native-search-paths]: Use the $SSL_CERT_DIR/$SSL_CERT_FILE from (guix search-paths) instead of a local copy. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/cmake.scm12
1 files changed, 3 insertions, 9 deletions
diff --git a/gnu/packages/cmake.scm b/gnu/packages/cmake.scm
index 4207f14310..cf930c57fc 100644
--- a/gnu/packages/cmake.scm
+++ b/gnu/packages/cmake.scm
@@ -38,6 +38,7 @@
#:use-module (guix build-system gnu)
#:use-module (guix build-system cmake)
#:use-module (guix build-system emacs)
+ #:use-module ((guix search-paths) #:select ($SSL_CERT_DIR $SSL_CERT_FILE))
#:use-module (gnu packages)
#:use-module (gnu packages backup)
#:use-module (gnu packages compression)
@@ -229,15 +230,8 @@ using the CMake build system.")
(files '("")))
;; "cmake-curl-certificates.patch" changes CMake to honor 'SSL_CERT_DIR'
;; and 'SSL_CERT_FILE', hence these search path entries.
- (search-path-specification
- (variable "SSL_CERT_DIR")
- (separator #f) ;single entry
- (files '("etc/ssl/certs")))
- (search-path-specification
- (variable "SSL_CERT_FILE")
- (file-type 'regular)
- (separator #f) ;single entry
- (files '("etc/ssl/certs/ca-certificates.crt")))))
+ $SSL_CERT_DIR
+ $SSL_CERT_FILE))
(home-page "https://cmake.org/")
(synopsis "Cross-platform build system")
(description